Timeline went white/blank on Linux

I changed the mounts on which my projects and videos are on from smb to nfs. Everything seemed to be working but as I tested my shotcut workflow, I opened a project and noticed the timeline went white. Playback did work though. Unfortunately now the timeline window is permanently white. It’s even white when initially loading shotcut. I also tried creating a new totally local project (eliminate any nfs interaction) but it seems something happened to shotcut itself.

I closed the timeline and re-enabled it from the view menu with no change. I also performed a re-install with no change.

I’m have Shotcut 23.09.29 running on current Arch Linux.

Any ideas on how to restore the timeline?

1 Like

I have a similar Issue as well.

Timeline & Audio Loudness = White Box, video in Source while both are open causes crash

Operating System:
EndeavourOS Linux x86_64

It’s a Arch-Based Linux Distribution.

Shotcut Version: 23.09.29

Qt version 6.60

When I opened the app I saw that the Timeline was a white box like a blank webpage, right clicking didn’t do anything; I restarted the app and it was still like that.

I then clicked the Timeline Menu, added a video track and nothing changes visually, I went into scopes and opened all of them, Audio Loudness also had the same bug, however opening Markers fixed the Audio Loudness Bug.

The app also closes when I had both Adudio Loudness and Timeline open with a video in the Source, while both are a white box. I was able to replicate this multiple times by closing shotcut & opening it again.

Dragging a video down from the source to the timeline shows a little red x next to my mouse cursor.

I have tried restarting the app, restarting my computer, reinstalling the app through pamac from the ‘Official Repositories (extra)’ and removing it to then install it again, while also restarting my PC.

I also deleted the app cache, however I did not remove the appdata.

opening Markers was a temporary fix and no longer fixes the bug on the Audio Loudness section.

I was concerned that this had something to do with my PC having the power to it cut when I bumped into it; but seeing someone else have this error makes me think that’s not the case.

Is there a crash log or some other log that I can clear to add more info?
I am not sure where that file might be located.

It does not work on Qt 6.6. If you had looked around here there was another post just hours ago about it. You should use the builds we provide through our download page. Otherwise, we main developers don’t have the time and energy to also help the too numerous distros and other packages out there.

I did do a search but nothing came up. I suspect it is because “white” was misspelled in the bug report so might not have matched my queries. Regardless, I do apologize for the duplicate.

1 Like

I fixed the spelling in that post. Now, others affected are likely to find it through this thread or the other.

1 Like

Thank you. And thanks for all your work on this project!

I’m new and literally joined this forum because I am having this issue too. When I click on keyframes everything looks normal but not my timeline.

I struggle to understand my laptops hardware configuration beyond knowing I use arch linux but my bf understands linux lingo very well.

I have tried the AppImage version of Shotcut 23.09.29 on Arch Linux. It seems to work perfectly.

hello, I have been a linux user for 4 years but I am nowhere near confident with linux. If you could explain more I would very much appreciate your help.

  1. I know how to install/uninstall packages/programs with terminal and only terminal. I remember how to do some things but frankly I have no idea ‘why’ it works (if that makes sense)…moving on, I know how to search for things on terminal so I searched using the keywords ‘applmage shotcut’ and got zero results.

  2. therefore, I know I am missing something that must be fundamentally obvious.

pls help :cowboy_hat_face:

Hello, all you need to do is download the AppImage file add execute permissions, and run it.
The AppImage file can be found here.

“Linux AppImage” is what you need.

FWIW, I used a different computer (Debian) for my workflow last week but just tried it now again on the system that had trouble (been updated 2x since issue appeared) and it seems to be working without issue. Shotcut is still on 23.09.29 and QT 6.6.0 but I just tried my workflow and had no issues with the timeline or any other frames/windows going white.

Unfortunately I don’t know the specifics but hopefully if you run a full system update, this may go away now…at least for arch users.

See the linked bug above where it was already fixed for the next version. Some packagers may have integrated this patch.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.