Timeline Paging Enable/Disable

Since the Timeline Paging is a “Feature” and not a bug, it would be great if there was a setting to disable it.

Having the timeline jump forward or back while I’m editing makes it difficult and I have to visually re-acquire the position. This is more of an annoyance than a help.

Thanks for your time and effort!

For comparison

In summary,
Premiere offers 3 scroll options: no, page, and smooth.
Kdenlive offers no and smooth scroll.
Davinci Resolve, ClipChamp, and OpenShot only offers page scroll, but Resolve and OpenShot scroll by half a page.
Shotcut offers page and Center the Playhead (a form of smooth).

I do not like a UI with many options; it is an illusion of user friendliness. People have a hard time understanding from a text-only description especially if English is not the first language and those strings are not translated. People inadvertently toggle an option using a mistaken keyboard shortcut. Or they change it when trying to find and do something, not sure how to test the change, realize not what they were looking for, and leave it changed–only to discover at a later time that something is no longer working as before.

In any case, it is not out of the question that since we do have one option here today (Center the Playhead) that can be expanded.

That would be great!
I realize I could downgrade to a previous version but I like staying current with features and fixes.

Thanks again for your time!


I also want to echo kb3gkc comment. I seriously dislike this new feature and wish for a way to disable it. I have been using Shotcut extensively for years, and this change in the timeline scrolling is exceptionally horrible and a huge time waster.

For the next version I added a Settings > Timeline > Scrolling submenu with the options:

  • Center the Playhead
  • No
  • Page
  • Smooth

Thanks so much!