Timeline not visible

I am relatively new to Shotcut. I’ve been using it for a couple weeks and like it very much.
This morning, I double-clicked on a .mlt file to open a project that I started yesterday. The video shows as usual, but the Timeline does not. I tried toggling View/Tmeline and it still does not show. It makes room for the Timeline, but no Timeline is visible. I updated to the latest version 19.01.27; still the same. How can I get the Timeline to show? Could this be a bug?

Try View > Layout > Restore Default Layout and restart. If that does not work, reboot your computer. If that does not work, try changing Settings > Display Method (Windows only). If none of these work, then Shotcut’s use of OpenGL for drawing the UI is not compatible with the OpenGL or DirectX on your computer. But you can probably still use the Playlist to make simpler projects.

Thank you for responding quickly.
Timeline shows if I start Shotcut from a shortcut or the executable. I can then drag a .mlt file to the main part of the display and all appears working. Using Open File appears to work also. I can use the program, but double-clicking the .mlt file was working. I also tried clicking and dragging the .mlt and dropping on the shotcut.exe. This fails too. It appears that when Shotcut starts and uses a parameter to start, it fails. I verified this by executing this in a command line:
C:\Users\Charlie>“C:\Program Files\Shotcut\shotcut.exe” “\DESKTOP\Charlie\Videos\FilmScanner\Editted\reel 01-09.mlt”

The program is excellent. Just wished that this can be reviewed and maybe fixed in the next release.

The Shotcut installer does not create a file association. Of course, the portable version cannot either. You can easily do it yourself in Explorer by right-clicking and choosing Always Use this app and picking Shotcut.
I see some of the problems you are describing when drag-n-drop mlt to exe or using command line argument. It does not fail to load, but it does load incorrectly.

Actually, I take this back. It is working fine for me. When I thought it was not I was not loading a non-timeline project file (not all projects require the timeline). I am not able to reproduce your problem.

I tried a bunch of different .mlt files. Some worked when you double-clicked; most didn’t. It may be the contents of the mlt. Not sure. Anyway, all is working when you start shotcut and drop (or open) the mlt.

For Windows 10…
When you right click on an MLT file…

Find the Shotcut in Programs.

To confirm in Windows 10, hit the windows start button, type in “default”…

Scroll down the list and you will see this…

Every time you double click on an MLT file it will open with Shotcut.

I’m glad that this is manually set, and not forced upon installing Shotcut. Too many apps today assume you want their program to be priority for a particular file extension.

Although it would be a neat feature to have this as an advanced set up option when installing that someone could manually check box like as with clearing shotcut’s registry settings.

This topic was automatically closed after 90 days. New replies are no longer allowed.