Time Remap Filter Not Working After Converting File

I dragged an .mp4 video clip I had downloaded (from Pexels) into the Playlist, created a Video Track and dragged the clip to that, and when I tried to apply the Time Remap filter, got the message that the video clip contained ‘B’ frames, and therefore needed to be converted.

So, I converted the clip - first to Best, then to Better, then to Good - and each time tried again to apply the Time Remap filter.

Even though the filter dialogue appeared, there is no ‘Stopwatch’ icon, and no tick/check mark next to the name of the filter in the filter window.

Also no ‘Keyframes’ tab anywhere.

In short, it looks like I cannot apply the Time Remap filter to the video after converting it to .mkv, .mov, or .mp4.

Any ideas here, about how to successfully apply the Time Remap filter, and/or how to ‘treat’ or prepare the video clip so that it will convert correctly?


Can you please share a screenshot of the properties panel for the original source clip and again for the converted clip?

Also, can you share a screenshot of the whole Shotcut UI and where you are trying to apply the time remap filter?

Thanks for your reply, Brian.

I cannot get to this today, but will post screenshots over the weekend.

Hi Brian,
Here are the screenshots you asked that I post.

In your last screenshot I can see that you have successfully applied the Time Remap filter to your clip. The next step is to add/modify keyframes in the keyframes panel.

This filter is fairly complex and takes some practice. Have you watched any video tutorials on the filter? Here are some helpful videos:

Hi Brian.
Many thank for your reply.

I am feeling a bit red-faced right now, because I had been looking for the keyframes tab at the bottom of the Shotcut window to appear when I invoked the Time Remap filter - I never thought of (and probably never noticed in the Time Remap and Keyframes videos I have watched) clicking on the Keyframes button in the menu bar across the top of the screen to get the Keyframes features to appear.

Will try that, and will report back.

Thanks for the videos - yes, I have seen both of those, and have watched several others, some of them repeatedly, to get the concepts and application of those concepts into my head. I really like Joe’s videos, in particular.

Thanks again.

Hi Brian,
Clicking on the ‘Keyframes’ button in the top menu did the trick, in terms of being able to apply Keyframes - thanks for that.

I do, however, have one remaining question:

When I right-click on the diamond shaped keyframe type (in order to choose ‘smooth’ as an alternative keyframe type), ‘smooth’ is greyed-out; ‘hold’ is clickable - how do I get ‘smooth’ to be an option that I can choose for the keyframe type?

Thanks for all of your help.

Smooth keyframe type is not supported for time remap. There is some history here:

Essentially, “smooth” resulted in unexpected direction changes and we have not taken the time to mitigate that.

Thanks very much, Brian.

Will you be trying to resolve the problem with the smooth keyframe working with the Time Remap filter?

It is not very high on my priority list since most users get good results with the linear keyframes.

Thanks for your reply.

I am presuming, though, that the reason you provided smooth keyframes as an option is that there are situations in which they make a (positive) difference - is that right?

Right. Smooth keyframes seem to be more important for filters like brightness and gain.

That’s not accurate. The common effect of Speed Ramping can only be achieved through the keyframes being smoothed out for that gradual change in speed that is signature of that effect.

1 Like

In Joe’s video, he demonstrates how to simulate the ramp effect with a small handful of linear keyframes. I think it is pretty compelling. I think our senses are less sensitive to step changes in speed than volume or brightness (for example).

Right. He’s simulating one. It’s not actually Speed Ramping. Also I wouldn’t say it’s compelling considering that it takes him a while to even get that simulation going. That’s why he edits out the rest of his efforts in getting that set up and cuts to the end result. And of course, he is only doing that as a workaround because there is no way to smooth out the keyframe animation.

Thanks, Brian and DRM.

Yes, my impression was, as DRM said, that the smooth keyframe option would be the way to go for Speed Ramping.

This topic was automatically closed after 90 days. New replies are no longer allowed.