Time lapse procedure in Shotcut

I shoot time lapse videos by programming my camera to shoot one frame every x number of seconds. Then, I stitch them together into a 30 fps file in VirtualDub. It works, but it’s a little clunky and it only exports as an .avi file. I’d like to be able to streamline this process and do it in Shotcut. Is this possible? It seems like it should be.

Currently, I’m importing the .jpg’s into a timeline and then I drag them down to the track. From there, though, I’m not sure how to tell Shotcut to play them at 30fps. And I’m not seeing a tutorial/How-to on the subject. Can someone point me in the right direction? Thanks in advance for your help.

Example posted to demonstrate what I’m trying to accomplish.

Add them to the Playlist. Check the box for Sequence in Properties of the first jpg. Enter desired dimension , frame rate etc in settings. Export directly from playlist (this is key). Don’t drag to track on timeline. Also helps if the first file in the sequence is numbered like name_xx1.jpg

1 Like

GIMP-2.10

Thanks so much for your quick response. I have the files in my play list and I haven’t dragged them to the timeline. Image sequence is selected and I have my frame rate at 1080HD 30fps in video settings. This is what I see when I pull up Properties (sequence is checked). I’m not sure what “Repeat 1 frames per picture” means and I’m not sure how to set the images to be shown at 30 frames every second.

Don’t touch the 'Repeat … '. Just export from playlist. It will export at the 30 fps you’ve already set using 1 jpg for each frame. I usually set the duration of the first jpg to 00:00:00:01 (makes the jpg 1 frame long), but I don’t think it matters. Try with about 100 jpgs first to see if you’re getting what you want, then load the full 3000 :slight_smile:

Thanks again for your response, and thanks for your patience on this.

So, for simplicity’s sake, I imported 30 frames (numbered sequentially) and have my video settings at 1080p 30fps. When I export, I theoretically should have a 1 second video clip, but instead it’s 2 minutes long.

Here is a screenshot of my Properties box:
GIMP-2.10

Sorry, I was offline. That sometimes happens to me also. The properties are fine. Check in the player . Probably what you want is in the first second. Place cursor press O there and export, that should do it

No problem; I do appreciate you getting back to me as you were able to. Unfortunately, I’m still not able to get the results I’m expecting, even after going to player, making sure the cursor is at 0, and exporting from there. I’m getting a much longer video than I should be. Is it possible that Shotcut isn’t the best option to accomplish this task?

No no, your timelapse is probably the first second of that 2 min long export. So check and trim it to the first second. Shotcut does the best job with timelapses, no restriction on size etc, I’ve tried others. Your 30 jpgs are in the first second (30fps). Just confirm and trim from the playlist itself.

1 Like

An easier way to do this is to not use the playlist. Just open the first image, go to Properties, and check Image Sequence.

3 Likes

4 Likes

Thanks everyone who helped out. This works great and will be my preferred method of putting together time lapse in the future.

3 Likes

Are you really sure you prefer GUI programs like Virtualdub or Shotcut for this kind of a task? With large number of frames it could become cumbersome.
My suggestion would be ffmpeg. Consider a command that creates a video of many images taken every minute during a month, at 25 fps skipping 4 frames out of 5 and scaling them down:
ffmpeg -framerate 125 -pattern_type glob -i '*GOPRO/*.JPG' -c:v libx264 -vf fps=fps=25,scale=1280:-1,format=yuv420p output.mp4

Actually, Shotcut is now my preferred application for creating time lapse videos from still images. It can’t get much easier than two clicks to finished product.

1 Like

Another outstanding tutorial, Ben.

1 Like

Thanks! Hopefully that covered everything