The vertical timeline indicator is in the wrong place

What is your operating system?
Windows 11 Pro

What is your Shotcut version (see Help > About Shotcut)?

Shotcut version 23.12.15

Can you repeat the problem? If so, what are the steps?

The vertical timeline indicator is not placed at the beginning of the video (after “Zoom Timeline to fit” is set), but outside it.

1 Like

Yes, this is a pretty old little annoying bug. I kind of remember that it was reported once or twice, a long time ago…
I hope too that it gets fixed one day.

1 Like

I can also duplicate the issue.
The playhead is in the correct position, rather the view is obscured because it’s behind the track header.

Workaround: Click Zoom Timeline to Fit again.

Same as this bug reported:

Unfortunately, I didn’t know how to report this error, I hope it will be fixed soon.
crossfinger :slight_smile:

Workaround: Click Zoom Timeline to Fit again. works, thanks Your help!

In theory this should work because it was fixed…

I’m not sure I would classify this as a bug from my perspective. Depending on which scroll setting you have enabled, the timeline might or might not follow the play head. It is possible to play an area on the timeline that is not showing if you are zoomed in and scrolled elsewhere in the timeline. In the case of the video linked, the play head is just before the visible area zoomed in the timeline, so it’s technically “where it should be,” and it shortly scrolls into view. If it’s an offputting visual scenario, I suppose the bottom half of the play head could be obscured until it reaches the X position that is greater than the boundary of the track titles. I can see why it would be confusing to some people.

Thank you for the screen recording. I can see the problem as plain as day. But for some reason I can not recreate it.

Can anybody guess what I am doing wrong? Maybe there is some other aspect to the problem like video mode or screen resolution? I’ve tried dozens of times and the cursor is always in the correct location.

1 Like

The problem starts when the clip or clips take almost all the space in the timeline.
The timeline starts scrolling while there is still an empty space on the right.

Hi Brian,

This fault also appeared with other video files (avi, mp4), regardless if size.
This is a link of the video file, You can download it free.

It’s normal for me too. no problem. ( SC v23.12.15 )

Après avoir cliqué sur “zoom to fit” vous devez encore zoomer plus.
Mais pour moi, ce n’est pas un bug, car la playhead est sur sa bonne position.
Peut-être suffirait-il de ne pas l’afficher si elle est en dehors de la zone.

After clicking “zoom to fit” you need to zoom in even more.
But for me, it’s not a bug, because the playhead is in its correct position.
Perhaps it would be enough to not display it if it is outside the area.

file : timeline.qml : line 637 (Rectangle id: cursor)

visible: timeline.position > -1


visible: timeline.position * multitrack.scaleFactor - tracksFlickable.contentX >= 0

This also happens when opening up an existing project, or Open MLT XML As Clip.

This project has no audio.

For me, opening up this same project with version 23.06.14, then zoom timeline worked great.

The only difference in the application log was the audio driver listed in the last line.