The Undo Trap

Today I split a clip and added half a dozen filters, spent a lot of time working on them, then made the grave error of licking Undo.

All the filters disappeared. I tried to undo one filter setting but everything were destroyed. I then tried Redo but that only brought back the split clip and none of the filters.

What the… I said. After a few unbelieving minutes I turned on the Hisory pane and witnessed what I didn’t want to believe - that Shotcut did NOT save most of the editing actions I took, i.e. before Ctrl-Z or Undo one must look at the History to confirm what it is that he is about to Undo.

The only counter-measure that a Shotcut user could take is to Ctrl-S like mad. Not bad, at least there is something we can do to protect our time investments.

It’s truely amazing that a relatively mature application like Shotcut could fall so short on a super-basic feature like Undo. Isn’t it something that most apps got right by version 2.0 ?

Just remember to avoid Shotcut’s Undo like the plague, and Ctrl-S like mad, and when you need to rollback your last keyframe adjustment, provided that you remembered to Ctrl-S before adjusting that keyframe, you should close down the app and re-open the project to its last-saved state.

Yes, it is so annoying. It has caught me out several times. But hopefully this will be sorted out soon-ish - see the first item on Shotcut’s roadmap:

In Progress

  • undo/redo support for filters

This topic was automatically closed after 90 days. New replies are no longer allowed.