The MP4 video looks different than video in Shotcut


#1

Greetings,

I was looking for guidance to understand why my video looks different between the view in Shotcut vs. the MP4 in the QuickTime player. As you can see in the QuickTime player, the screen is skinny and tall compared to Shotcut. I even increased the standard resolution and aspect ratio to improve this before exporting, but no luck.

From what you can see in the screen shot, are my settings off? Or is there another method to record the video preferred? Currently, I’m just using the video mode in my iPhone XR. Maybe’s a preferred app to use to get better video quality.


#2

Let’s try something, click once on the video (in your Finder window) then hit space bar instead of double clicking on the video.
Is the video still stretched?

Please also post the settings you have your Shotcut’s video mode set to.
Mine shown below, yours may well be different, depending on what you want to export as:


#3

Hi,

On the first request, I clicked on the video file name once in Finder then hit the space bar, but nothing happened after that. I probably did not follow your instructions correctly.

Also, below are setting for the videos used in this file. As you can see no settings were selected.





#4

When leaving the “Automatic” resolution activated, the first file you import, Shotcut adapts to that resolution for the entire project.
2019-03-11_03-15-44
Looking at your playlist, file #1 (possibly imported first) is not the same resolution of the other files.
2019-03-11_03-17-08

Make a duplicate copy of your project file and try to change the video mode, although I have seen mixed results on attempting to change the video mode after your project has started.


#5

Your first screenshot looks like you tried to export using the Quicktime Animation preset. That is unlikely what you want since that is mainly for video with areas of transparency. That format is supposed to save to .mov format, but you must have done something to override it as MP4. Maybe you selected that preset and then started changing things in Export. I see you have enabled the Advanced mode of Export, but do you consider yourself an encoding expert? If not, perhaps you should turn that off and try just using the defaults, which are designed to give the majority of people the majority of what they are for when trying to export. To use defaults, do not click anything in Export except Export File, or if you already changed something click Reset or the Default preset.


#6

Thanks for your guidance. Since my first file was an audio file, this made a difference in using the wrong file type for the video files. Also, leaving the features as is when exporting made the viewing much more clearer.

Brad