Text resizing (grow/shrink) is not smooth

Good afternoon,

I’m using Shotcut to make a video with added text. The text should appear small in one place, and more to another place while slowly growing in size.

Using keyframes (and the simple text filter) I can achieve the effect that I need, but when rendered, the result looks bad. The movement (if used separately) is smooth, but the ‘resizing’ seems to only happen every 10 frames or so, like the text is not able to be rendered with the size in between. So the text just jumps up in size a few times per second.

Is there any way to avoid this and get a smooth result? There are only two keyframes in use: one for the ‘start position / size’ and another to set the ‘end position / size’. Should I provide more details?

Oh, by the way, my version (windows 18.11.18) instantly crashes when attempting to add HTML text… so that’s not an option for now it seems.

Can’t seem to duplicate what you’re describing. I created a 1080p 60fps short video of just 6 seconds to demonstrate.

Make sure you have ticked the icon which activates the Keyframes (green box). If you want different sizes within the clip at various times, and sizes, just put the playhead where you want it, and move the box surrounding the text in any direction you wish. Resizing works as well.

At the very end of the clip, position where you want it to end up at, if you want it at the end of the clip. You can move the diamond icons at any time. Just clicking the diamond shape once, will allow you to resposition/scale (with the box surrounding the text) wherever you would like it.

My only thought would be is before you export, restart your computer, have nothing else running, even turn off your anti-virus as software running in the background could affect your export. Exporting a video is very CPU intensive, so when you start exporting, it’s hands off the keyboard and time to do the dishes until finished. If you an SSD or NVME/M.2 drive inside your computer, put all of your source material on the SSD or NVME/M.2 before making your project, so when exporting, it’s not pulling from one physical spinning hard drive (HDD).

I wouldn’t consider the text editor to be a well oiled machine, as I’d much rather work with a transparent png with text. It’s personal preference. For those who don’t wish to edit their own text graphics, the text filter is perfect.

You can clearly see the different between the two in this video:

And you may notice some weird black/gray shadow around the text, that was intentional, as I made it this way in GIMP.

First of all, thanks for the detailed input Hudson.

It’s a weird thing. I am (and was) doing pretty much exactly what you’re saying.

  • Now I tried with a clean, blank, project with text on a transparent png and there seems to be no issue
  • When I use my ‘problem’ project (with heavy 4k video) the problem is still there

So perhaps it has to do with the second half of your explanation (the drives/CPU being busy and such). It’s weird that this could be the cause - from my (limited) perspective I would thing that busy hardware would cause the render to take longer, not the quality to be different…

There is recommended computer minimum specifications to use Shotcut. For 4k video, it’s a 4-core CPU, 16GB Ram, then the link goes into Operating systems and drivers.

Mixed frame rates and/or Variable frame rates could be an issue as well. Does the Video Mode match the source frame rates? Without knowing particulars of your source material, project settings, it’s difficult to give any more advice.

There is a difference between preview and export rendering. By default, preview rendering drops video frames to attempt to make make the audio continuous and achieve near real-time speed. You can turn that off in Settings. In Export, it always renders every frame.

This topic was automatically closed after 90 days. New replies are no longer allowed.