Text overlays not showing up

I’ve been trying to edit a video together, but when I try to export it, the text overlay never shows up. Part of the issue may be the fact that I used a black PNG with a Rich text filter to overlay text over the video. However, I’ve tried replicating this issue with another clip and that exported fine. I’ve tried switching what layer I put the text image on, but it doesn’t do anything. The weirdest thing to me about this was the fact that another image overlay that’s in the same layer shows up just fine somehow. Can anyone tell me what I’m doing wrong?

Clip from problem video: vs AKENAGA X edit 6.0 highlights test 1.mlt (34.8 KB)

I don’t have your media, but I’m guessing you had problems near the end of your video with the black image.

In Shotcut, for text, it’s best to use a transparent color.

  • Open Other, Color, default is set to transparent. Drag from source to the timeline. Use the text filter of your choosing.
    No need to apply a chroma key filter.

It doesn’t appear to have any video on V1. You may need to have video on V1 to get your text on V3 to show up.


Shotcut 21.03.21

You need to change the font typeface and color. You are using MS Shell Dlg 2, which does not work and with no color defined. Color defaults to black since it is based on HTML where the default is black text. However, the UI shows it as near white because the editor defaults to the UI theme’s text color when no color is defined. And when using the Shotcut dark theme, the text color is near white.

2 Likes

Thank you, Dan! I didn’t notice that the text was that color. I just got around to changing the text from black to white like you said, and it worked!