System does not save position

Hello friends. As I have shown in the attached picture, when I make these settings and turn SC off and on, it returns to the default settings.

Here is my analysis

-Laptop also records when I make these settings. It’s okay… OK.
-The PC does not record when I make these settings. Default is coming in Registry…

  • I am currently using SC v23.05.14. but this was also the case in previous versions…

Register Path : \HKEY_CURRENT_USER\SOFTWARE\Meltytech\Shotcut

Have you tried to remove and re-install shotcut, think there is an option to reset the registry setting in the installer

Yes, I tried.

But tell me, when I create a custom layout myself, (after making the desired settings), when I restart SC and load this custom layout, the settings come. But when I open the mlt file again, it goes back to default…

This has happened before, I wrote to the forum again… then I solved the problem with the *.reg file… but I don’t remember how I did it right now…

but the registry path is correct. Settings are here…

It would be helpful if you provide steps to duplicate the issue.
I have tried several different ways, but have not been successful in duplicating your issue.

It’s unclear what layout you are using. There are 6 default layouts at the top, and your only screenshot shows that you have one selected. You further state that you created a custom layout. Did you name the layout?

I modified one just by dragging panels around and resizing them to something hideous as this:

Closed Shotcut and restarted.

Closed Shotcut once again and restarted, opening a different mlt project.

You can also reset any of the 6 layouts (at the top right) by having that layout selected and clicking on “Restore Default Layout”.

And after closing and restarting Shotcut:


now the script is like this sir

Let’s just take the timeline. it’s at the bottom of this screen. i’m raising this up to make room for the kilps.

at this point it doesn’t save it.

Otherwise, there is no problem in creating and loading custom layouts. problem with reset. no. resets.

but the desired position does not come.

Problem screen

Wanted screen

selection edit


but again problem screen…

I want to make sure I’m understanding what you are trying to show.
Is this what you are experiencing?
Moving at least one panel then selecting one of the layout at the top/right?


no choice. I’m only getting the timeline part up. and i want it to stay that way

  • but if i choose eg if i choose edit. then it is as you say.

  • I think there is the same problem with the screenshots in the first messages you sent. ie the working area for V1…A1 etc… is too narrow!

  • In other words, the default setting of the “Edit” option is desired.


Hi. How can I make the “editing” part stay fixed, like the attached image? I made a few adjustments but without success. When SC restarts, Timeline returns to default settings again…

This narrows my workspace… ( TimeLine )

  • I don’t want to choose the layout that I created myself every time.

SC v23.05.14
Windows 10
Monitor 24"
Display 1920x1080 Resolution

Weird it works for me.

Yes. It also works on my laptop. It might be related to the PC… I don’t know.


I tried it on Linux, it records the panels at the desired setting when exiting from SC v23 05 14 … without any problems…

I tried it on another computer today. same situation there. :frowning:

Is there something in the default settings? I mean, does it reset automatically at startup?

help please… @shotcut , @brian

Windows 10 TR