SVG import size wrong

What is your operating system?
Windows 10, 64 bit

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
Shotcut version 20.07.11 64 bit

If I add an SVG file, made by Affinity Design, and exported as a 1920 x 1080 SVG file, Shotcut imports it and reports it as a 100 x 100 pixel file, and displays and exports it as very low resolution on the screen. If I use a PNG of the same file, it sizes perfectly. I have tested the SVG file on KDEnlive, and it sizes correctly.
I have tried to upload a screenshot of what I see, and an example SVG file. I have tried different SVG files at different resolutions and sizes and they all report as 100x100 pixels.

The Fair Use image should be the full width of the view window.

Fair Use.zip (1.1 KB)

This is a bug in the version of Qt libary we are using. When I test in Linux Flatpak with Qt 5.14 it works as expected. The SVG has width="100%" height="100%", and I think the version Qt 5.9.7 that we are using in our builds drops the percent and treats the values as pixels. It will be fixed the next time we upgrade Qt, which is expected very soon.

Thanks for the response. I appreciate your work.

Hi, I just changed width to 1920 and height to 1080 and it works. You probably did that yourself but I’m just reporting it in case you didn’t.

1 Like

Hello JonRay
Thanks for your information.
Where did you change the size?
In the properties it is a read-only field, and the Size and position filter was sill low resolution.

IIf you open the SVG file in a text editor (like Notepad++) you will see tat the third line starts:

<svg width="100%" height="100%" viewBox="0 0 1920 1080"

Edit this line, save the file then use the new file in Shotcut.
.

Opened in Notepad, edited line 3:

Oops, I just realised @elusien posted a minute ago!!

Thank you

Thank you for your help

While this is somewhat specific to my case, but it may help other people.
I use Affinity Designer to make my static screens, and I see that SVG export has an option to turn off the viewBox in the “More…” menu. The export file then writes width and height as pixels, and doesn’t write the viewBox parameter, and the resultant file works with ShotCut.
Thanks for your help, and the pointers in the right direction to solve my issue.

2 Likes