Stutters/unsmooth result on encoding (Solved: Wrong video mode for timeline)

I’ve made some gaming videos with success, but my recent project is causing me issues. (You can see my YT-channel for working full lenght video. One of the latest ones.)
End result after encoding has stutters on the main image, the picture in picture portion seems ok.

My source material is:

  • XACV-S (1080p) HD 100Mbps 50p shot with Sony AX53.
  • gaming video recorded with OBS, x264 CBR 20000 Bitrate, 50fps, mp4-file.
  • Few .PNG picture files.
    Video materials details on shortcut side are like identical.

I have tried exporting the video with multiple different fine tuning things on “H.264 Main” profile and also with “Youtube” profile.

Resolution: 1920x1080
Aspect ratio: 16:9
FPS 50
Mode: Progressive
Deinterlacer: YADIF (best)
Interpolation: Bilinear (good)
Parallel processing checked

Codec: Libx264
Rate control: Constant Bitrate
Bitrate: I have tried now from 20M to 100M (20M it wasnt so noticeable, but felt like it was still there.)
Buffer size: Default 224.
GOP: 25
B frames: 2 and have tried 3 also
Codec threads: 0
Dual Pass checked


Other tab:
Have left these default

Examples on youtube. Sorry that video is not the same, but you can see the effect it has; even on youtube side. Just look at 1080 50fps mode.
Look closely on first seconds how the cars move on screen and when I take the gloves.

No Stutters:


What else I’ve tried to do to trouble shoot:
-Encode using material on my RAID SSD or Spinning drive
-Different encoding presets as stated above; ones that have worked before.
-Started constructing different kind of videos. Small to Big method.
- I was able to encode working smooth video that had all the features that I wanted (3 video tracks blending etc.) and material from all my source files, just clipped short. (No stutters video is the “all features” short-vide that I made). But when I make bit longer one (Full qualifying laps, but not the race section yet) I got the stutters again. Same encoding preset and settings. :frowning:

Is there a part on my source material that is causing an issue? Buffer size on encoding?
My PC specs:
Intel Haswell i7-4790K, LGA1150, 4.0GHz, 8MB
Asus Z97-PRO(WI-FI AC) USB 3.1, LGA1150, Intel Z97
Kingston 16GB (2x8GB) HyperX Fury, DDR3, 1600MHz, CL10, 1.5V
Zotac GeForce GTX 980 Ti AMP! Extreme, 6GB GDDR5
Two 120G Kingston 120GB HyperX Fury SSD in RAID0

What could be the root causes? It has worked just this week when I recorded some other gaming and made a video.

Or should I just discard that material and try again next time. :slight_smile:

Regads: Antti

Ok, I think I found the issue. :grimacing:

Noticed that My Master timeline was set to 25fps, even though the Setting -> Video Mode was on Automatic.
Still I was able to export back to 50fps and that 50fps->25fps->50fps was probably causing the issue.

Why Automatic had detected my video settings to 25fps, even though all my source material was 50fps?
Why it hadn’t done this to me earlier; even though I had used very same workflow when making the video? Pure luck?
…Should have noticed this as my Encoding page was giving me 25fps as default after picking the preset; and before that was always on 50fps already.

Well, almost 12hours of noob troubleshooting. :sweat_smile:

I’ll report back when I create the full video and encode it. (In few hours.)

Automatic detection is the cause of lots of problems and questions here(though it always works for me all my stuff is 16:9 and 30 or 60 fps, Make sure your project is set to 50fps when importing at the beginning and you’ll avoid issues like this.

Probably because the first thing you put in your project was an image or audio file. In that case, Shotcut needs to start with something, and it defaults to 1920x1080 @25 fps.

It must have been the thing that happened there. I actually first added a “black color” from “open other.”
Makes perfect sense now. I just wish that shortcut would prompt a dialog when you start a new project. You could set the basics of your project. May be personal preference, but used to something like that on so many other editing softwares.

But video encoded during the night. Looks butter smooth as it should. :smiley:
Thanks for the help and replys guys.

:edit: Updated the topic

This topic was automatically closed after 90 days. New replies are no longer allowed.