Stuttering worse in 18.05

I recently upgraded from 18.03 to 18.05. My source material is a 30 minute 1920x1080i 29.97fps (variable) MPEG-2 TV recording. I normally use default export settings with mp4/libx264. There is a lot of stuttering (judder?) when converted with 18.05, much more than I saw after converting the same video with 18.03.

I have tried changing GOP frames (down to 12) and B frames (from 3 to 2) and Quality up to 75% from 60%, but nothing seems to change or reduce the amount of stuttering. What other parameters can I try?

I do not want to export the video to “edit friendly” format because it will be gigantic and take a long time. I just want to convert it like I did with 18.03. But I would like to find acceptable settings with 18.05 so I can stay current with the shotcut releases.

Thanks in advance for any help or advice!

If you’re talking about the preview playback while in shotcut (or when editing), then export it and get back to us if it’s still ‘stuttering’.

As mentioned recently,I had issues with laggy/stuttery video in Shotcut where once it was smooth playback until I uninstalled the program then re-installed it choosing the option to remove all settings, this fixed it.

The MPEG-2 source playback while I’m in the shotcut editor is flawless. The original source looks great in both shotcut and VLC. But the H264 mp4 export is a jerky stuttering mess when I play it in either shotcut or VLC.

I tried the re-install with clearing all registry settings (is that what you meant by remove all settings?) and I get the same results. I used complete defaults for exports, no tweaking. 18.05 stutters badly. Re-installed 18.03 and no stuttering at all in the final output.

Also, FWIW, I noticed that the default GOP in 18.05 is 150 and B frames is 3. I tried my 18.05 export again with GOP =12 and B frames = 2, but there is no apparent change. Still lots of stutters and flutters.

I missed this first time.
This could be the problem, VFR doesn’t play well in SC. Perhaps you can first transcode it, I know you said you don’t like to but you just may have to bite the bullet on this one.
Can your TV recorder be set to Constant frame rate?

This is OTA ATSC content recorded via Silicondust HDHomeRun. I’m not aware of any way to change incoming VFR to constant bitrate, but I will look into that.

There must be a way for shotcut to do this properly! It worked fine with shotcut 18.03 and earlier versions and the MPEG-2 VFR playback looks great in the shotcut 18.05 editor, so I know this particular clip “plays well in SC”

I just encoded the same clip with handbrake - Fast 1080p30 settings and it also looks fine. Something in shotcut has regressed in 18.05.

OK, sorry I was just recalling many other posts over the past moths where folks were reporting VFR clips causing issues and the Devs mentioning that the problems with VFR are known.

Edit friendly export takes >30 minutes; I just tried it. I cannot afford that delay in my workflow since I often process several shows daily and the conversion from un-edit-friendly MPEG2 to mp4 only took about 6 minutes in SC 18.03 for a 30 minute show. Adding 30 mins to that process is too much.

Thanks much for your ideas, so far. I don’t mean to be rude, but this is frustrating. SC is a terrific editor and until 18.05 it did exactly what I wanted, converting from MPEG2 to mp4 after I cut out commercials all in one place.

I will just stay with 18.03 for now…

I cannot think of anything that changed between these versions that would cause that. Did you any filters? I have some ATSC recordings I will try to reproduce it.

Did the Settings > Video Mode get changed somehow?

Can you share your computer specifications and operating system?
Is your source material on a HDD, SDD, USB drive, NAS?
If you do have a mlt file that works with 18.03 but doesn’t work with 18.05 you can share that file here just by dragging it into the reply window.

Possibly more information might help out the developers figure out the issue.

I have a 123MByte (1 minute 11 second) trimmed version of the MPEG-2 source which demonstrates the problem. Is there some place where I can upload it? (tried to upload here, but .ts extension is not allowed)

Did the Settings > Video Mode get changed somehow?

Not that I am aware of. I do a complete uninstall/reinstall between 18.03 and 18.05. I simply export the video with full defaults in each release. Settings -> Video Mode is automatic. I do not use any filters.

computer specifications and operating system?

AMD Ryzen 7 1700 Eight-Core, 3 GHz, 16GB RAM, Windows 10 version 1803

source material on a HDD, SDD, USB drive, NAS?

source and export destination are the same SSD a 224GB mounted as windows G:

Upload completed at 6:39AM Eastern. 122514 KB “Modern Family Intro.ts” was the original filename.

I also reproduced the problem on v18.03. You must be getting intermittent results. For some reason, the combination of YADIF deinterlacer, Export > Video > Parallel processing, and this file format (MPEG-2 video with B-frames in MPEG-2 Transport Stream) is a particularly challenging combination. The workaround is to do one of in Export > Video:

  • set Scan mode to Interlaced,
  • turn off Parallel processing
  • or use a different deinterlacer.
1 Like

I just tried with Linear Blend Deinterlacer and it seems… fine! Thank you. That is a perfectly workable solution. And it’s good to know that there are other options to fix it as well. Although I think interlaced scan mode is a step backwards, ha ha.

Your sample clip is interlaced, but Shotcut export defaults to progressive since that is what most people want. Depending on your needs and your playback devices, then interlace might be fine.

My primary playback device is Roku. Roku does not play 1080i or any interlaced content, so I guess I’m with most people - wanting progressive content.

While I appreciate that de-interlacing will technically reduce my original material quality, it is still the best alternative for me. Thanks again. I am thrilled to have a tunable solution to the stuttering problem.