Stabilize not working

I recently got a new computer. Was running Windows 7, but now Windows 10. Stabilize feature works on old computer, but not on new computer. When I click Analyze, it looks like it is working, but gives me a “failed” message just before it reaches 100%. I tried downloading an older version, but that one also does not work. Any suggestions?

There were some changes to the Stabilize filter in the new beta version which might resolve your problem (it seems OS specific, though…). (

1 Like

How do I download the latest beta version?

Get it here.

1 Like

It worked!!! Thanks so much.

Well, stabilize worked, but now it fails to export. Any ideas?

Windows 10 using v19.08.05.
Used 3 different clips with different resolutions for stabilization.
2 from timeline 1 from source. All were analyzed and exported.

There might be something about the clip you’re using that’s causing your export problem.


This topic was automatically closed after 90 days. New replies are no longer allowed.