Speed filter not showing correct clip length in Timeline

I’m using 24.02.29. I’m using the speed filter on a triimmed clip (duration is larger than timeline in the properties). I set a part of the clip speed to 0.35x by keyframe and 1x for the rest of the clip. But the clip length is not extended in the timeline.
I tried to change clip “duration” to a longer value (according to an old post talking about this problem, but I’m confused because the duration is the length of the untrimmed clip and is already longer than the timeline value), but the length is not changed and it also makes the speed filter no longer working (always 1x).
If I cut the clip into 3 pieces and set the properties/speed to 1x, 0.35x, 1x individually, the length will be longer than using the speed filter. How to fix this problem? thanks.

Clip properties shows 2 durations: source and timeline. Filters are not capable of changing either clip duration. Timeline duration is not editable numerically at this time: only by interactive trimming or splitting. So, after using a time/speed filter that requires a longer duration you first try to use trimming on the timeline to make it longer. Then, when you cannot extend it longer because it has reached the source duration, go to Properties and override the source duration. But that does not change the timeline clip duration; you still need to use trimming to further extend the clip duration.

Another approach: before adding the time/speed filter, go to Properties and increase the source duration by an hour. That will likely be enough. Now, you don’t have to worry about limitations, but you do need to pay attention to the last frame repeating if you make the timeline clip too long.

Wow, thanks for your quick reply!
I just tried your solution. Now it can be done by setting longer duration and trimming (make it longer on the timeline). But it’s difficult to determine the correct length of the clip after the speed change. If I trimmed it too long, the last frame will stay, if it’s too short, the clip will be cut too much. Also the audio waveform is not changed by this method.

This topic was automatically closed after 90 days. New replies are no longer allowed.