Something is Seriously Broken with Shotcut!

Something is bugged with Shotcut’s undo and redo features. Several times when pressing “undo” or “redo”, random alterations will occur that I cannot reverse. This includes desynching audio and video, converting audio tracks into video tracks, creating random spaces between clips, and ultimately causing me to start over again. In each project that I have tried to create, this has happened to me. I will not be using Shotcut again until I know that this is fixed.

1 Like

This happens to me so I avoid using these buttons more than once or twice at a time and edit with this limitation in mind. It’s probably a complex coding issue so it doesn’t bother me


Very insightful, you are correct. I wish more forum users could be as resilient as you.


What is your Shotcut version? Go to Help > About Shotcut to see.

Hey @Molsen
Undo/redo option is still not supported for filters. It is on the roadmap.

Most probably, this is the reason you’re experiencing this.

This topic was automatically closed after 90 days. New replies are no longer allowed.