Some video black in export, some flashing blue

Ubuntu Linux 21.10

Shotcut-Version 22.01.30 (snap install)

I made my first steps with two different raw materials on the source side. I have recorded an Introduction with 1080p on the front camera of my Google Pixel 4 5G and later recorded the rest of the video in 4k (30Hz) with re rear camer of that phone.
When I export the created video with the Youtube video defaults for 4k the videos with raw material in 1080p is shown black with only audio. The other parts encounter random blue flashes and glitches in birghtness. I tried with and without hardware GPU support.

Then I tried exporting the whole thing in 1080p 60Hz resulting in exactly the same problems.

Sometimes in between I had the opposite problem. All the media in 4k got black in the playback. Then I saw that the properties of the media didn’t show anything. I had to re-select the video stream for each snippet of video in the time-line.

Any idea what I am doing wrong?

Did you use Detach Audio anywhere in your steps?


No, just had some 1080p video from fron and 4K from the rear camera attached together in one export stream.

I moved to windows for a trial and did the whole video again, exporting it to 1080p. That ended in a video where the 1080p part was exported fine, but the 4K part is audio only with black screen.

So currently I am cutting it all again after taking all the 1080p shots again with the rear camera in 4K.

On the older windows machine, editing is a bit slow, but with the proxys it helps a lot! However I also added proxies in the Linux run, so no idea if that is the problem.

I don’t know what is wrong. There is not enough information. Sounds like problems reading your files. You should show properties of them. Also, in general, with problems like this, where it seems to have trouble reading and decoding, you should use Properties > Convert on them and use the converted files.

I got a bit further… To be honest, I did not read the instructions.

However, I thought using proxies does help in speed on slower machines and I could cut everything a bit faster using proxy settings “on”. I actiavted proxies and the software asked me to wait and restart after that setting. I did. The proxys where automatically created in 1080p and working on the project went smooth.

But exporting the project in 4K failed with black video and audio only, just the Intro played visualy, as it was based on just a png picture with some FX.

Watching some YT tuts on shotCut, they say that proys are for speeding up the workflow but export is done in original quality.

I tried disabling the proxy setting and re-exported the video, but getting again only a black video.

Then I checked the properties of all the sequences and found the track setting on the video is set ot “empty”. So I had to run all the time-line for each and every piece of video, select it, and select the 4K track for the original video.

With that some FX got messed up, what may be a bug, where the above might be a user error. The FX kept the end settings, but lost the beginning time stamp. So a text that I inserted at a short sequence ended where it should but the beginning was set to the end of the video somehow…

Export took me 2,5h for the video just ot find that I missed another sequence of scenes to set vor the right video track… So I’ll try it again.

So is there a bug in the proxy thing or do I do something wrong?

This topic was automatically closed after 89 days. New replies are no longer allowed.