Some clips suddenly stop functioning

I’m a vocational instructor working for a Berlin media academy and we use Shotcut in some introductory video production classes. While I work on a Windows system (and have had very few problems at all with Shotcut), my students use Macs that are supplied by the academy. Several of them have experienced the following problem:

OS: macOS Catalina v10.157
Mac Book Pro (2019)
CPU: 2,6 GHz 6-Core Intel Core i7
RAM: 16 GB
Graphics: AMD Radeon Pro 5300M (4 GB).

Shotcut-Version: 22.04.25.

Occasionally, a video clip that used to play perfectly fine will suddenly only show as a solid white color when played either from the timeline or from the Playlist. The thumbnail still looks okay but there’s no way to get it to play. What’s more, even trying to re-import the original video footage will not change anything – it seems as if this particular footage clip has been “destroyed” once and forever within a particular Shotcut project.

We found a couple of workarounds:

  1. Create a new Shotcut project – the same footage will work fine in the new project (but still not in the old one).

  2. Open the Properties window for the faulty clip – the Video tab is no longer accessible (even though it was a minute before). But if we manually create a new Proxy clip from the Properties window, both the Proxy clip and the original clip are usable again.

I did see the entry in the FAQ list „All I see is white or green instead of video, and I know there is video in this file….“ but the suggested solution „make sure GPU Processing is disabled in Settings“ doesn’t apply to Apple computers, does it? The item in the Shotcut Settings menu doesn’t even exist, nor do we seem to be able to access OpenGL in the Mac system settings.

Actually, to me the whole problem looks like some form of cache issue. As the clip does play fine initially and stops doing so out of the blue (so far, we haven’t been able to determine just what’s causing it), and then won’t even change when we re-import it, I suspect a file in some internal cache is corrupted in some way. And Shotcut doesn’t re-create it until it is forced to do so when it needs to access the original footage file for rendering a new proxy file.

Is there any way to empty/reset an internal cache? Any other suggestions? We’ve had the problem occurring on several workstations, at irregular and unpredictable intervals (hence no screenshot). Thanks a lot for some input!

Does each computer have its own version of that clip?
Or are you using some sort of network where they all access the same file from one source?
Have you tried to change the clip’s location? (Move to other directories or even to a different drive)

Are you using Anti-Virus programs? If so, try turning off the Anti-Virus.

You can choose Settings->App Data Directory…->Show
This will open a file browser. You can start deleting things in there. Shotcut will rebuild anything it needs when you start it up.

Ah - you mean literally deleting EVERYTHING? We tried deleting the contents of the Cache folder, that didn’t do the trick (forgot to mention that yesterday).

Thanks for the quick reply anyaway!

By the way: is there any way to contact you more directly? I’ve put together a few remarks about the German version (some translations aren’t correct or missing) and a few suggestions and wishes.

Yes, all participants work on their own computers and copy all clips onto their own drives. Also, it’s not the same clips that stop working on different systems. Like I said, it’s all totally unpredictable and erratic.
Moving them to a different location didn’t work either.

We’ll try the Anti-Virus idea, though - I didn’t think of that, thanks!

Yeah. Why not? What do you have to lose?

I’m pretty sure there is nothing in the cache folder that would cause your issue. I would try to delete the entire folder. If you have some presets that you like, you should save those somewhere else so you can restore them.

Another suggestion I have: If you can make a bare minimum project that demonstrates the problem, save the MLT file. Then, do your proxy trick to “fix” the problem and save the project with a different name. Post the two project files here (broken and not broken) and we can compare them. Maybe there will be a hint in the broken project file.

Translations are handled in Transifex: Shotcut localization | Transifex
It looks like the German translations would benefit from more contributors.

Feel free to use the Suggestion category on this forum. Consider searching first to see if someone has already made the same suggestion.

I use the macOS version often and never experienced this over 10 years.

Yes, but it is hidden because it is experimental. If it you have it on, it would be the first thing in the Settings menu to make it easy to turn off.

There is no file cache in Shotcut - only a cache for thumbnails and waveforms, which you said is not important. There is, however, an operating system file system cache.

A white frame in a video clip means there was an error getting the frame’s image. The same problem will make the Video tab in Properties unavailable. Sounds like there is a problem reading the file. That is why Hudson’s question about using the network is important. Perhaps the problem can also occur if someone opens the file before it is done copying, or if it is modified somehow.

You mention in your first post that when you create a new project the footage works fine, but fails in the old one.

If possible could you upload both of those project MLT’s? We don’t need your media, just the project files. The MLT project file is just lines of code that tell Shotcut what to do with your media.

Are all of the projects working with the same Shotcut version 22.04.25?
Are any of these projects created with an earlier version? If so, then what was the prior version number?

This topic was automatically closed after 90 days. New replies are no longer allowed.