[SOLVED] Video does not fit inside the viewport

Hello folks,

I got Shotcut yesterday, and I do like it. The issue I have is that after importing a clip, it does not scale with the viewport, so the image is hidden behind scopes/panels, which is not ideal. I cannot find where to scale (zoom in/out) the preview or fit the viewport.

Any help would be appreciated.
Thank you.

I cannot shrink the application small enough to hide any part of the preview, so I don’t know how you managed it. The preview scales just fine.
(Assuming you have all panels ‘docked’ and not floating?)

Which OS are you using? This is important.

1 Like

Hello, Steve.
Thank you for replying.

Docked or floating? I didn’t see anything about that in the menus, I just clicked the buttons to show the scopes/panels, but the preview is under those panels.

Here are images of the default view and with panels displayed. Even in default view, parts of the preview are beyond the viewport (scroll bars).

DEFAULT VIEW:

WITH PANELS:

I’m using Manjaro Linux.

From your screen capture… you have zoom enabled in the player window.
zoom3

Just click on the icon here then select Zoom Fit
zoom2

Shotcut doesn’t reset the zoom automatically when closed or going to a new project.

1 Like

Aha, I have never even clicked that button.
Good call.

1 Like

I never have either, but without the screen shot from the OP I would have been left scratching my head.

If zoomed other than Zoom Fit, Shotcut will not resize player window, thus sliders, as you move panels around. If not “Zoomed Fit”, will highlight the zoom icon even though you have not pressed it for a new project or reopening Shotcut.

For the OP, or others reading, if you do need a bigger window to see, and don’t wish to zoom in, and have two monitors, you can use this feature.
external%20monitor%201

1 Like

Ah-ha, thank you. I didn’t even realise that I’d clicked on it. Never noticed the magnifier, not even with dark theme. I was trying CTRL + scroll wheel to change the size. that would be a nice feature, I think.

Anyway, thank you for getting back to me and helping out.

That’s good useful info. Thanks.