[SOLVED] Transition maintain audio


#1

Good Morning Community,

First THANK YOU for Shotcut.

I have created training videos demonstrating operations of a specialized medical software package.

At certain sections of the video, I need to zoom in and zoom out. I followed the tutorials for “rotate” and that’s easy enough.

I don’t want a hard transition though. I want a dissolve transition between the two segments, but I have audio happening during these transitions. So when I overlap, the audio gets mixed which is NOT what I want.

Forgive me, DaVinci Resolve has a transition that does a dissolve transition between two clips, and does not interrupt the audio at all.

An example is at this video: https://www.youtube.com/watch?v=PInNTmyzJb4&t=9s

Go forward to 0:09 and watch the next 5 seconds.

My question is: How do I do this in ShotCut?

Thank You!

Dave


#2

Put the audio on an audio track and it will not be mixed in the transition.


#3

Add an audio track, copy the video clip(s) and paste it/them to the new audio track. Mute the video track.

image

However, you might want to get the latest version 18.05 and use the keyframe-capable size and position filter for smooth zooming.


#4

Thank you both for the reply…

If I put the audio on a separate track and overlap the video, now I have a synchronization issue…But I think I have a solve…

I watched the tutorial video…Can you please verify that my scenario below would work?

a) Put the audio onto a separate track.
b) At the transition point (split), drag the ends of each video to add extra frames but not disturb the overall length of the video.
c) Do the overlap transition with these extra frames and we now have a good transition, and no audio sync issues.

I’m going to try it - but do either of you have any issues with the plan above?

Thanks!

Dave


#5

I’ve got it working. It’s clunky - but it works.

Here is how…

a) Split the track
b) Turn off snap
c) Separate the clips
d) Trim the end of the first cllip to lengthen it by one second.
e) Trim the beginning of second clip to lengthen it by one second.
f) Turn snap back on and snap the clips back together.
g) Turn off snap, and drag either clip a over b or visa versa by exactly two seconds.

Bingo - nice smooth transition, and the audio stays in sync and you don’t have to separate the audio from the video track.

Thank you to all who responded…

Dave


#6

@dcbdbis I tried this and it worked very well. The only thing I did different was to keep snap on.

You might want to mark this a solution for others who might have this issue.

Try this and see if it works. Create a normal transition. Select it. Then in the transition properties panel select Mix and set the slider all the way to B. See how that works.

image


#7

Which audio player are you using If it is VLC then it is not possible to solve this. The only thing that you can try is by getting the orginal version and for this you need your visa card details.


closed #8