*SOLVED* Text doesn't appear in export

What is your operating system?

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.09.27 64bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

I cannot repeat the problem, as shown :

The top two are the problem. The bottom two is trying to recreate the problem. I added 3 Rich textboxes, one with default font english, default font japanese, then the target font japanese. In the attempt to repeat the problem, they are all exported properly.

More information:

  • I have several text slides without the apple clip art, and they don’t show either.
  • Text is all on the highest layer.
  • Text slides were made by [Open Other > Color > Black, then Filter > Text: Rich].
  • I have tried using Text:simple, it doesn’t export either.
  • I have tried changing DPI settings

Here’s the log: https://pastebin.com/ERBVzUk2

Edit 1: I added a Text:Rich box with the default font and “Shotcut” text in the timeline and only that exported correctly. Currently going to try different fonts and languages next.
Edit 2: So I added a new Text:Rich box with the same exact text, font, size as what I had previously and it’s exporting now? So I guess I have to go replace every text box now but will report back if fixed.
Edit 3: Solved! Well that was dumb of me but I’m gonna keep this up incase someone else has the same problem.

Was this problem fixed already?
I encountered same problem with following OS/Shotcut versions:

MacOS: Catalina, version 10.15.7
Shotcut: version 20.11.28

I use scrolling-up text feature of text-rich. It shows on Shotcut preview but not on export.

Try deselecting the filter, like this, and then export.


1 Like


It works!!!
Thank you very much for your help.
I really appreciate it.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.