[Solved] Proxy creation failed

I have proxy creation enabled, but when I added a video taken with my drone, it failed to make it (use to worked with other versions). I tried with Manjaro package, with Shotcut Appimage downloaded yesterday and with my previous appimage.

The error is this:

ffmpeg version n5.0 Copyright (c) 2000-2022 the FFmpeg developers
  built with gcc 11.2.0 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-amf --enable-avisynth --enable-cuda-llvm --enable-lto --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdav1d --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmfx --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librav1e --enable-librsvg --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libsvtav1 --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvmaf --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-libzimg --enable-nvdec --enable-nvenc --enable-shared --enable-version3
  libavutil      57. 17.100 / 57. 17.100
  libavcodec     59. 18.100 / 59. 18.100
  libavformat    59. 16.100 / 59. 16.100
  libavdevice    59.  4.100 / 59.  4.100
  libavfilter     8. 24.100 /  8. 24.100
  libswscale      6.  4.100 /  6.  4.100
  libswresample   4.  3.100 /  4.  3.100
  libpostproc    56.  3.100 / 56.  3.100
[h264 @ 0x55b395d2b180] Reinit context to 3840x2160, pix_fmt: yuv420p
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/media/datos/Drone/Pico Austria/Videos/DJI_0094.MP4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 2022-05-29T17:58:56.000000Z
    encoder         : Lavf56.15.102
  Duration: 00:00:33.70, start: 0.000000, bitrate: 103600 kb/s
  Stream #0:0[0x1](und): Video: h264 (High), 1 reference frame (avc1 / 0x31637661), yuv420p(progressive, left), 3840x2160, 103600 kb/s, 29.97 fps, 29.97 tbr, 30k tbn (default)
    Metadata:
      creation_time   : 2022-05-29T17:58:56.000000Z
      handler_name    : VideoHandler
      vendor_id       : [0][0][0][0]
Stream map '0:a?' matches no streams; ignoring.
Codec AVOption b (set bitrate (in bits/s)) specified for output file #0 (/media/datos/Drone/Pico Austria/Videos/86b395a618c493c7131459970c990216.pending.mp4) has not been used for any stream. The most likely reason is either wrong type (e.g. a video option with no video streams) or that it is a private option of some encoder which was not actually used for any stream.
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> hevc (hevc_nvenc))
Press [q] to stop, [?] for help
[h264 @ 0x55b395f6e280] Reinit context to 3840x2160, pix_fmt: yuv420p
[Parsed_scale_1 @ 0x55b39a03a1c0] w:-2 h:720 flags:'' interl:0
[graph 0 input from stream 0:0 @ 0x55b39a03c640] w:3840 h:2160 pixfmt:yuv420p tb:1/30000 fr:30000/1001 sar:0/1
[hwupload @ 0x55b39a03bf80] A hardware device reference is required to upload frames to.
[Parsed_hwupload_3 @ 0x55b39a03be40] Query format failed for 'Parsed_hwupload_3': Invalid argument
Error reinitializing filters!
Failed to inject frame into filter network: Invalid argument
Error while processing the decoded data for stream #0:0
[AVIOContext @ 0x55b395d2fc00] Statistics: 0 bytes written, 0 seeks, 0 writeouts
[AVIOContext @ 0x55b395d326c0] Statistics: 7243088 bytes read, 2 seeks
Conversion failed!
Failed with exit code 1

Video is: H.264 (High Profile) - 4K

As I said, this used to work before, with the old Appimage that use a previoud ffmpeg version gave the same error.

I can’t understand from the error what part is the problem, maybe the color configuration?

Thanks!

Turn off Settings > Proxy > Use Hardware Encoder. It is not working on your system.

Thanks!