Sluggish with longer files

Wondering if I have a settings issue or something simlar.

I started using Shotcut last year on my olf comptuer. Old being a 2nd gen Core i5 with 16gb RAM. The program ran perfectly fine on that machine…even hours long files could be edited with very little slowdown.

I upgraded to a new computer a few months ago - 10th gen Core i7, 32gb RAM and now the program is almost unusable on files longer than 15-20 minutes, or even shorter files with lots of edits.

Dropping large/long files into the preview is quick, but when moving from preview to the timeline is when the issue start. An hour long (1-2gb) file might take 5+ minutes before it fully loads in the timeline and can be manipulated. From there every move of the shuttle or edit tends to hang or the program becomes unresponsive for a bit. In most cases I have to edit larger files down in another program and use Shotcut when I have a smaller/shorter file to deal with.

Any suggestions of settings I could check? It seems odd that a new machine would give issues where a 10 year old one was fine. Doesn’t seem to be the files themselves as I can open them in Opencut (shudder) and have zero issues.

I have got these types of problems before when I upgraded to a machine with 256gb ram. For me, I didn’t knew that some of the drivers were not installed, and was running a older version, but when I got attention to it, I solved the thing, and it worked fine until my ram physically broke out, but I changed my ram stick, and it again worked fine.

You can also try to reinstall shotcut with checking the box of delete registry settings in the installation wizard.

Or reboot.

Although you are trying to compare different generations of Intel CPUs against each other, you are missing one crucial specification. What is the speed of each CPU? There are 10th gen i7’s that are slower than 2nd gen i5’s.

Many other factors go into consideration trying to compare one computer to another. Cooling of the CPU, software environment, data drives, anti-virus programs.

Also, consider that the video you are trying to edit may have a variable frame rate when it didn’t on your old computer. Unfortunately, not all video is created equal.

It is also possible to have a miss-match of FPS (Frames per second) in your project. Leaving Shotcut in Automatic for a Video Mode can be good and bad. If you load an image first into your project, it will have a default frame rate of 25fps. Then you load your video into the project not being the same frame rate can also cause issues. Recommended that specified Video Mode from the start, before opening any media into Shotcut.

If you can provide more specific details of your computer or laptop, along with your video file specifications, we can help you out further.

If in fact, you do have a lower speed CPU, you may want to consider using Proxy editing.
Here is a tutorial on how to get started with Proxy editing.

1 Like

You may have a point with overall clock speed. The current computer is a 2.7ghz clock while the old machine was probably 3.2-ish (it’s on the shelf as a backup and not easily accessible). that said I can’t see that by itself being the culprit.
The old machine would obviously chug while importing and exporting a large file (although it was momentary), but looking at system utilization during these processing it was understandable as it was using up to 80% of my system resources for these tasks. The current machine never breaks 10% of CPU and RAM usage stays under 2gb.

Current system specs are:

OS Name Microsoft Windows 10 Pro
Version 10.0.19043 Build 19043
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name MSPC
System Manufacturer ASUS
System Model System Product Name
System Type x64-based PC
System SKU SKU
Processor Intel(R) Core™ i7-10700F CPU @ 2.90GHz, 2904 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1003, 11/30/2020
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product TUF GAMING B460M-PLUS AC
BaseBoard Version Rev 1.xx
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = 10.0.19041.1151
User Name MSPC\canoo
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 18.2 GB
Total Virtual Memory 36.7 GB
Available Virtual Memory 13.4 GB
Page File Space 4.75 GB

Old machine used an ATA SSD drive, new one uses NVMe. I use included Windows AV which has not changed from system to system.

One example of a file that chokes the program is;

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.2
Format settings : CABAC / 3 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 3 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 2 h 8 min
Bit rate : 944 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 60.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.008
Stream size : 865 MiB (78%)
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709
Codec configuration box : avcC

I’ve set Shotcut to 1080 x 60fps and pulled the file into preview. Opens right up. I drag to the timeline and it’s now been about 20 minutes and the program is still basically locked up. It’ll unlock for a moment until you click anything then it becomes unresponsive again. System utilization is still next to nothing.

I’m sure it’s something I don’t have set up correctly, but it’s being difficult to track down.

One thing you can try is turning off Waveforms and Thumbnails in the timeline.

I just tried that and it didn’t help in this specific case (same file as detailed above)

This did work for me, I am not sure about the cpu clock speed problem, but I have noticed that my newer cpu has 4.8ghz which runs faster than my old 2.8ghz. Also utilizing the more amount of cores available. I am using filmic Pro to record in AVC, with the same stream size.

It becomes a little bit unresponsive while opening, but did work in a minute after hang, it slows down for a minute after each single change, because my file is 3 hrs 12mins with me editing a big birthday video, and a lot of colours captured in the video.

I am working with a Intel Core i9-10900X X-series.

I did check about your cpu on, maybe you can compare both of cpu’s there, because it has all the information about intel’s cpu’s. And decide to stay or switch your cpu.

I am not a professional at solving windows related things. Maybe stay for some days, and see if it works.

If Shotcut more depends on the clock speed rather than cores, does it mean Shotcut not optimized enough and need to be rework rather than ask user to use the old CPU? I am curious whether Shotcut team have put this optimization plan in their short term roadplan ? Because the way i see it for the last 3 beta, its about add more features, but actually Shotcut itself already rich in features

No, shotcut doesn’t depend more on clock speeds.

I would say it’s more depended on cores, my upgrade was from a 4 core to 10 cores. And I only notice that the cores are increasing performance.

I have also used a intel xeon platinum 8362 at a cyber cafe, it has the same amount of clock speed as a intel i3 3rd gen cpu, i.e. 2.8ghz, but it’s more cores makes shotcut run faster than that 4 cores of a i3.

But shotcut mostly uses upto 8 cores only.

The reason why they have only features in roadmap is because there monthly updates are only focused on performance improvements, so they don’t need a roadmap to make it happen.
And even making a roadmap for that seperately or together, makes no purpose for me.

Sometimes it is about clock speed, sometimes it is not. Sometimes it is about GPU, sometimes it is not. Sometimes an antivirus program slows things down. The factors that lead to a sluggish user experience are complex and often times unique to the user’s specific computer. It is helpful when people share what changes have helped them improve their user experience, but that does not mean the same change will help another user because their situation may be unique.

Sometimes we are able to identify specific areas of code that can be optimized to improve the experience for many users. But it is often difficult to identify those code areas because we do not have access to every user’s computer hardware and software configuration.

I completely understand, great work and you all gpty utmost respect!

I had this problem (on an i7 Surface Pro with 16GB RAm and 170GB free disc. I tried a number of things and then saw that several others had had the same problem and had to revert to an earlier version of Shotcut, as later ones semed to be struggling with some computers.
I reverted to 20.07.27 and it has worked OK since (earlier versions are available online).

That’s a good suggestion. I didn’t know they offered old versions this way.

I’ll try this and see what I get. Thanks!

All of the older version for Shotcut are located here: Releases · mltframework/shotcut · GitHub

That seems to have worked from my limited testing. I picked an older version at random (20.10.31) and had to make an edit to a 45 minute file today and was able to navigate it quickly. Much better than any other time with this newer machine. I’m guessing it’s an issue with something in the newer versions of SC and this computer.

This topic was automatically closed after 90 days. New replies are no longer allowed.