Slow exporting with good pc specs

Hello, I’m trying to export my lightly edited 14 minutes video and it says that it will take like an hour. What can I do to fix that problem? My specs are: CPU: 11th Gen Intel(R) Core™ i5-11400F @ 2.60GHz 2.59 GHz, GPU: 1070 GTX and 16GB of ram.

Hi @Slajq
How long did it actually take?

You could try setting the Parallel Processing option on the Advanced tab in Export:

Check if nvenc hardware codec is enabled.

Be aware though that Hardware Encoding often produces much larger exported files that can be of poorer quality than those created using software encoding. Also, quite a few people on the forum have complained that their exported videos contain only audio, with no visuals and most of these problems have been circumvented by unticking the “Use Hardware Encoder” option.

1 Like

I’ve tried changing this setting, didn’t really change anything.

45 minutes or something like that

It is enabled.

Personally I would try disabling HW encoding and enabling parallel processing and see how that fares.

I’ll try that later.

You were right, if you turn off hardware acceleration, the file takes up less space without sacrificing quality. Now I’m sorry that I didn’t know about it before.

Did it take any longer to run or was it faster exporting?

I checked myself.
If the project consists of cutting a video file, then hardware acceleration gives an advantage. If the project consists mainly of motion graphics and animation, I don’t see the difference between hardware and software encoder, sometimes even libx264 is faster than h264_nvenc.

That is not always true anymore, but it is with this poster’s generation of NVENC. Size depends on rate control and quality percentage is not normalized across codecs.

It took a lot less now, thanks for the help.

I used to use Premiere Pro, and it took ages. Whenever I export a file now with ShotCut, I always go do something for a while I just think that rendering can take ages on many programs, especially with filters. I’m certainly no expert though.



This topic was automatically closed after 90 days. New replies are no longer allowed.