Size, Position and Rotate filter is very laggy

The other day I recently updated to the newest version of Shotcut, and I’ve realised that when using the Size Position and Rotate filter it was suddenly very laggy. I realised my Shotcut playback was set to 1080p 25fps so I set it back to 1080p 60fps. There were no problems before I updated, and now there is? I have a GTX 1080 so it should probably be better than this

Is there any way I can fix this? I’ve tried turning Realtime off along with Scrub Audio and Progressive, but nothing has seemed to work.

Any help?

First of all, Shotcut is generally laggy and people complain about it so frequently I usually simply no longer respond to posts about it.
Now, for the new version 20.10.31 release notes

Improved image quality when using Size, Position & Rotate .

That can make it slower. It also depends on Settings > Interpolation. I am not going to reverse that change. The image quality is more important. The usual remedy (as mentioned in the FAQ) is to use

This topic was automatically closed after 90 days. New replies are no longer allowed.