ShuttleXpress /ShuttlePro V2 in Linux (Ubuntu)

ShuttleXpres or ShuttlePro V2 is possible conect to Linux.

  1. Drivers: the current linux kernel knows the Shuttle Xpress/V2 and has the right drivers
    (test: To demonstrate ShuttleXpress is completely functional: sudo apt-get install evtest
    And then: sudo evtest /dev/input/by-id/usb-Contour_Design_ShuttleXpress-event-if00
    If you can see the responses as you jog ShuttleXpress, you did it )

  2. There is a free project at ShuttlePRO if problem try: Shuttle GO
    aimed at ShuttlePROv2 but that also works to ShuttleXpress. My steps were as follows.

Download and extract the zipped files to anywhere you wish (I sent it to my home directory).

There are some changes to be made in order to make the soft work with ShuttleXpress.

Open “shuttle” and change the path to what you got from “ls /dev/input/by-id/ | grep Contour” (in my case “/dev/input/by-id/usb-Contour_Design_ShuttleXpress-event-if00”).

Then, open “99-ShuttlePRO.rules” and rename “Contour Design ShuttlePRO v2” to “Contour Design ShuttleXpress”.

Now Shoot:
apt-get install build-essential libx11-dev libxtst-dev
cd ~/ShuttlePRO-master
sudo make
sudo cp 99-ShuttlePRO.rules /etc/udev/rules.d
sudo make install

Make sure everything is in place:
ls /usr/local/bin/shuttle; ls /etc/udev/rules.d/99-ShuttlePRO.rules

To start running just do:
“sudo shuttle”

If you can scroll the terminal by wheeling the jog, you just did it.

To stop the soft, just “Ctrl + C”.

                                                           *(Thanks atipico*8 )
  1. Configuration:
    Open file manager with root axes: sudo nautilus
    Copy the example.shuttlerc file to /root/.shuttlerc and edit it there.
    Instead of " [Defauld] key" whrite yourself code or paste my SuttleXpress code:

K5 XK_Control_L/D XK_Z XK_Control_L/U
K6 “x”
K7 " "
K8 “S”
K9 “B”
JL XK_Left
JR XK_Right
S-3 “-”
S-2 “-”
S-1 “-”
S1 “=”
S2 “=”
S3 “=”


  1. sudo shuttle
1 Like

That’s very helpful. Thanks!

1 Like

Hi Adam,

thanks for the trick, it works perfectly with the internal “wheel/jog” howerver I got the following error : “jogshuttle(11,120) invalid code” when I use the external one. do you have an Idea on how to solve this by any chance ?


Hi, after some digging into the issue I found also some newer app called Shuttle Lander which seems to work without any tweaking. At least for Shuttle Pro 2 on Ubuntu. Its just install the package, reboot and it works. It has a graphical configuration interface to config the buttons, which is kinda nice compared to the text file with weird codes :smiley:

The project is here:

1 Like

My Linux computer recognized something, I could use the outer shuttle wheel to scroll in a browser, and in Shotcut I could shuttle fwd and back (backwards to logic, Left was fwd!). Installing Shuttle Lander and things went bad: computer won’t boot (hangs on splash screen), but unplugging boots OK. How do I get this thing (Xpress) to work?!! It doesn’t help that I am new to Linux (MInt), and have a small brain… Thank you

Lacking information to make a truly informed response, other than the mention of Linux mint, however…

The first thing is to completely remove/purge lander, followed by a manual removal of any config files/folders in your local directory. Then you should reverse all other steps you tried before installing lander, including any steps you might have tried from this thread (you did make a note of these system changes right?). Basically, take your system back to BEFORE you tried installing anything related to your Xpress version.

After that do another boot and either start again with lander from scratch, or follow the gjthub instructions here (which are similar to this thread):

Then see if you can boot your system with the device connected. If not then it might be time to check your boot log, and maybe do some digging in dmesg to see why it is hanging.

In all likelihood you will probably get a more thorough response on a forum dedicated to Linux, and one that might walk you through the steps in greater detail.

Thank you! I’ll try to get back to before. I usually am good about record keeping for changes, but I did run some terminal code to prepare, something I saw either in the Lander info . AAargh. Everyone not only raves about the Xpress, but all say “it worked (on Linux) right out of the box!” It doesn’t help that Linux and the Terminal are all new to me. But thank you, I will try this road.

@rokket I ran into the same issue except I didn’t realize it was the ShuttlePro stuff. I was doing a new build and too many things to track back without rebooting in between. I punted and just re-installed debian all together…

Any how I suggest installing Timeshift. I started making backups anytime I make changes. Even if you bork the whole system, you can use a bootable usb and restore.

Thank you! I messed things up adding “video stuff” to my new build (every codec and driver ever conceived), and re-installed Mint. I know the feeling of loading and tweaking. I’ll give Timeshift a try and re-try Shuttle. I love the unit, very solid and seems fine, other than not being able to actually use it!

I did notice on the old install, that turning the shuttle wheel was default opposite to what I’d expect. Left I would think would BACK, and right FWD, but it was reversed. Same for using it to scroll vertically in a web browser. Maybe it’;s just me.

No problem! After replying, I was going to try the GO solution. I had installed the original on my new install and it didn’t work, but it didn’t bork my system either. I moved on for a week or two and didn’t do anything with it. Before uninstalling it, I figured I’d see if I could assign commands in the gui and check one more time… and it worked? Odd indeed. I’m on a new stable of Debian so maybe there was an OS patch that allowed it to work, but idk… Anyhow, it’s working now, mostly. It’s hung on me a few times making window focus/window management all f’d up, but using the keyboard alone and getting to terminal and running “systemctl restart shuttleworker.service” has fixed it each time. I can live with that. I’m just happy it’s working!

In case you were unaware, being new to all of this… Mint is an Ubuntu based distro, Ubuntu is based on Debian. Many of the same things apply to both of us.