Shotcut working really choppy on decent PC

Hey there, I just started doing Youtube and I realized that I need video editing software.
I was reading much about it and I decided to stop on Shotcut.

I like that it has a really user-friendly interface. For me, a person who never used that kind of software, only for a couple of hours I learned how to basic edit my video (how to add transitions, how to cut it, etc) which is nice.

The main problem is that the program is working choppy. After every single operation like (move clip in the timeline, cut it, add some effect) it freezes for few seconds. This makes the software some kind of unusable.

Probably the problem is a due fact that I’m trying to edit 4 hours video (1080p@60), 12 GB size.

My PC is not that bad: Ryzen 5 5600x + RTX 3070. 16 GB ram. Is this because I’m editing the video on my HDD instead of SSD?

I have tried y stopping some settings like - Realtime, set preview scaling to 720p but nothing helps.

Also, it looks like it uses mainly CPU instead of GPU.
I’m using Linux, btw.

As the FAQ states under minimum system requirements in the link here

16 GB RAM is actually the minimum required for 4K.

Try out the lower Preview Scaling settings and use it together with Proxy. You can find the link on how to use Proxy in the FAQ above.

Thanks for your help.

I’m not trying to edit 4k videos, but 1080p.
In system manager, I see that Shotcut is using about 5-6 GB of my RAM.

I’ll check for this “Proxy”. Thanks.

My mistake. :slightly_smiling_face:

Let us know how it works for you using both Preview Scaling and Proxy. Remember to try a lower setting than 720p for Preview Scaling.

Sure, I’ll try it. I lowered the preview scaling to 540p (I don’t want to be very low after all) and enabled the Proxy.
At that moment the proxy is still creating (really slow process, maybe because the video I’m editting is big).

Hello, also a beginner here, have been doing very simple editing (editing over the air US television shows that have been DVR’d to remove commercials) for about one year and I think you might be able to largely remove that slowdown by going to the timeline tab and turning off the “Show audio waveforms” option. You access the options by finding the Timeline tab (probably at the bottom of the screen) and clicking the three horizontal lines (should be in the top left corner of the Timeline tab.)

Ok, definitely with these settings (preview scaling and proxy) is far better. The Shotcut is actually usable for me now. Thank you very much. :slight_smile:

@WadeMasshardt Thanks. This helps a lot, too.

what version of shortcut are you using?

The newest one I think (21.01.29). But when I posted this thread I was using some older one (from Ubuntu repositories) which didn’t support proxies.

you might give 20.11.28 a try i’ve had issues with performance on 21.01.29 we’re still trying to track down.

1 Like

@D_S I have tried 20.11.28 but it crashed while I was working on the video.
So, I’ll stick with the newest one for now. It works good for me.

In your case, you may want to make your own proxies; you might be able to speed up the process. (That is, if you are going to be editing 4 hour 1080p@60 videos on a regular basis).

Experiment on a raw video, find a set of choices for the Export in the Video (set to 960x540) and Codec tabs that gives you an acceptable Preview quality, an acceptable Proxy file size and a very fast export time. and create a Preset and a Profile to save these.

Then for each new project, open first with Proxy OFF. On the Properties for each video (in a track, selected) the Proxy button has a choice to reveal the hashcode for that video file. Copy it, and do your Proxy file Export to a file named by using that hashcode, into the folder also revealed (or set) by the options on the Proxy button.
Now when you turn Proxy ON in Settings, Shotcut will use your proxy files and won’t try to create them.

I do this on every project now; in my case it is to reduce proxy file size, in your case it could reduce the time needed to create the proxies,

@kagsundaram Ya, I saw that the proxy is hash of something. Thanks.
I have no problems with the proxies now, and I don’t think I’ll edit 4 hours videos anytime soon.

However, I faced another issue (crashes when I’m playing with keyframes) right now, but it’s not related to this thread.
Where can I see crash logs to post a new thread eventually?


This is Dolphin on Kubuntu; it should be the same in Nautilus on Gnome Ubuntu.

If you can reliably reproduce the problem, posting a screencapture video might be more useful.

Since you are on Ubuntu, I recommend SimpleScreenRecorder

In shotcut choose the menu option Settings->App Data Directory->Show

1 Like

@kagsundaram yes, I can.

I just want to say that it looks like this crash bug is fixed in the beta release.

1 Like