Shotcut won't let me export my finished video and days my project is missing some files!

Hi, I’ve just finished a video montage piece of a music ensemble performing, 25 hours of work, first time on shotcut and I really got into the creative possibilities. However now I want to export it and submit it to my managers, and it is coming up with the message 'your project is missing some files. Saving, closing and reopening which is recommended, doesn’t stop this message from appearing again when I try to export. The computer did crash mid project, which I wonder if this had to do with the problem, but it opened again, with everything ok except the most recent changes (made since I last saved) and the file is now self named …repaired.mlt. all the original videos are still in the playlist, so can’t think what could be missing…
Starting to panic as I have deadline of tomorrow to submit this, it’s all finished and perfect, but I just can’t get it to export and lift out of the shotcut programme!! Please help!

Here is one tip, and when you go to that thread, there is much more on the subject.

What you have is a tiny fragment of a file, hard to find, somewhere on your timeline.
Since you say you had a computer crash in mid-project, that may be the cause of the fragment.

Thanks! I did that and choose one of the files I had used in my playlist. It seemed to work and let me save it onto computer, however when I tried to open it and play it… It says ‘this file isn’t playable. That may be because the file is unsupported, the file extension is incorrect, or the file is corrupt.’
So still not success. Any idea what I can try next?!

Look on your timeline, all through it.
Somewhere, at the place where the tiny “blank” clip was before, should now be a clip of the file you named when…

…sitting on your timeline where it is not supposed to be.

Lift (Z) that clip.

Ok, thanks, I’ll have a hunt…

1 Like

On another note, @Austin, do you have any ideas for @Sorrelharty

It sounds like you’ve covered the usual issues. If the project is on a removable drive, make sure the drive is getting assigned the same drive letter it was last time the project was opened.

Good point.

You need to wait for the export to finish! If you did, then perhaps you are choosing an export preset incompatible with your player or changing things incorrectly in Export > Advanced.

1 Like

Sometimes it is helpful to see if Shotcut can open the file if a player can not open it. Also, what is the size of the exported file?

1 Like

I think it was just having to process the export (for an hour or so!) as it did finally arrive onto computer intact and viewable!! Phew!

Thanks so much everyone for your help and great tips on getting around these panic inducing error messages on shotcut. Offering a seemingly random one of the source files back into it seemed to be what did the job, as then it was happy to export the video. This took over an hour to process, and I hadn’t seen the little percentage indicating something in process at first, and also something did appear in folder I was sending it to, but as someone advised on chat, I just needed to wait for it to finish sending! Patience!
I did spend some time searching through my timeline for a tiny parasite file which may have caused the glitch, but couldn’t see anything suspicious. It was a big project though with a lot of small snippets so maybe i missed it.
Really enjoyed using shotcut on the whole tho, so will be back to using it again, and no doubt on forum again as I inevitably will come up against some more issues along the way. Going to catch up on some sleep first tho (up till 4am sorting this out last night!!)

I’m glad to hear that you’ve eventually got the finished product working. If the “missing” file was named “BLANK”, then it is almost certainly a short (1 or 2 frames) gap between two clips, or near a transition. Dan is planning to prevent export from complaining when it detects this, so at least you don’t have to mess around with dummy file replacements.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.