Shotcut won’t start anymore (Ubuntu 16.04 snap)

I was thinking about reviving older topic Shotcut won't start anymore (v18.03 Linux snap) but then realized the actual issue is different.

I am running Ubuntu 16.04, and followed the easy steps for snap install. All went well for two projects. Now tried to create another video, shotcut did not start. I have assumed something went wrong during system update, but then found a way to get former version (snap revert shotcut --revision 71). It worked and I did not pay more attention.

Last night, while editing the video the app started to behave very strangely (different icons, etc). Tried to quit and restart, it did not start. Only then I started to troubleshoot, found that libc version in Ubuntu 16.04 does not meet current requirements. But I was fine with the version used so far and did not intend to upgrade.

It looks like snapd is upgrading packages unattended. Not sure how this is possible and I do not want to discuss this. Based on search it cannot be disabled by config, people use hacks like denying access to snap server. In any case donlt expect it will update apps/files currently in use, so that is another surprise. During the update it also removed the older revision so I was unable to revert anymore. Luckily the mlt files contain Shotcut version that created them. I was able to locate the version 20.09.27 download it and continue.

I am however unable to locate system requirements for the older versions. Did I miss some document in the download package itself?

My biggest concern is about the snap repository. I would expect that it should keep track of dependencies and not install packages on systems that do not meet them. Or is the dependency not setup properly in the shotcut snap package = shotcut bug?


Sorry about that inconvenience but our snap is not confined (classic), and it is not completely self-sufficient as you learned. In version 20.10 (release notes) I upgraded our base Linux OS image to try to improve compatibility with modern versions (e.g. hardware encoding, OpenSSL version loaded at runtime, Qt supported versions, and general bug and security fixes). Both the release notes and the FAQ page mentions this new glibc version requirement. The Flatpak does not suffer from this because it is fully confined. We welcome a volunteer to make a properly confined snap.

I would expect that it should keep track of dependencies and not install packages on systems that do not meet them.

I do not know much about that, but perhaps it assumes the snap is confined, will run on older systems, and app developers will not break things.


Thanks a lot for the confirmation. There is no doubt about need of upgrades and thanks for keeping things current. I was thinking of looking into the snaps to see how the package could be improved, but the approach of forced autoupdates is against my mindset and I am not ready to support.

What could be improved perhaps is a note at your download page, the instructions for installing snap could contain a clear warning that it is not confined, that snapd performs automatic updated and that it can break things.

Thanks for the pointer to release notes. It confirms that glibc version 2.17 is required as of 20.10.31. Still I am looking for list of dependencies/requirements listed somewhere in the previous versions. Found blog of 20.09.27 mentioning it is last version to support 32-bit Windows and macOS 10.10 and 10.11., perhaps Ubuntu 16.04 could be included at this place as well, at least until it is supported by vendor.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.