Shotcut timeline audio not synced with video

I’m having an issue with audio in shotcut being delayed on the timeline. Now, I don’t mean the audio is delayed in the exported video, the exported video is fine. I’m talking about the audio in the timeline being out of sync. For example, take a look at the audio clip on this timeline:

You’d think that the audio would start playing where the marker is, but it starts playing near the end of the audio clip instead. This throws off the timing of the audio clips. How do I fix this?

Can you show the rest of the interface? Maybe it is playing audio from a clip on a different track?

This is the rest of my interface. I have muted all timelines except one in order to isolate the problem.

Your post is a little confusing because “marker” means something specific in a video editor, and Shotcut does not have it. Thus, I assume the vertical line we call the playhead and other tools may call the “current time indicator”. Are you talking about the playhead or the beginning of the audio clip? Audio cannot be expected at the playhead because there is no clip with audio at this time. If you meant the audio clip, sometimes files do not seek properly. This is especially noticeable in the editor during preview because you seek around a lot while in export it simply processes sequentially. In that case you need to convert the file that is being a problem. You can select it and use Properties > Convert.

Sorry for the confusion. I didn’t put the playhead where I meant to put it in this image. I meant to put it here.


I’ve just tried converting the file, and the issue still persists. Also, what do you mean by files not seeking properly?

(FYI I recently bought a new computer and downloaded shotcut on it. I used shotcut on my old computer too, but only encountered this issue on my new computer.)

If this is a consistent problem across media (test several video files), then you can use Settings > Synchronization… to compensate for a system-related playback problem.

When you move the playhead outside of simple playing then it is seeking. Not all formats or files handle that well.

I just went into synchronization and turned it all the way to 200, and that seems to have solved it. Thanks!

This topic was automatically closed after 90 days. New replies are no longer allowed.