Shotcut suddenly stopped working properly

So, I’ve been using Shotcut for several months, created several small projects with it. No issues.

today I sat down to start something, and Shotcut was behaving poorly. Playback of clips wasn’t working at all. Hit play, get maybe one or two frames, and then it freezes. Menus pull down, but don’t do anything. Program has to force-quit or kill -9 from the command line.

I’ll attach a full log of the console output to this message, but here’s a clip of what’s happening when a clip is dropped into the playlist:

[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] [consumer sdl2_audio] Audio Opened: driver=pulseaudio channels=2 frequency=48000
[Warning] [consumer sdl2_audio] audio timed out
[Info ] Failed to open audio device: Too many open audio devices

Playback freezes here. Menus still work. When you attempt to exit, this is the console output:

[Debug ] MainWindow::closeEvent begin

Nothing happens after this. It has to be killed.

shotcut.log (3.7 KB)

This system did receive a pulseaudio module gsettings update from Ubuntu on 3/7:
From my dpkg.log:

2020-03-07 10:14:06 install pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status half-installed pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status unpacked pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 install pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status half-installed pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status unpacked pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 configure pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status unpacked pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status half-configured pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status triggers-awaited pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 configure pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status unpacked pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status half-configured pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:06 status installed pulseaudio-module-zeroconf:amd64 1:13.0-1ubuntu1.1
2020-03-07 10:14:10 status installed pulseaudio-module-gsettings:amd64 1:13.0-1ubuntu1.1

The last update to pulse components was on January 20, but I’ve used Shotcut since that update without issue.

Attempting to roll back this update looked to be extremely messy. Rolling back the pulse components would have rolled out most of gnome and trashed the system.

Are there known problems with Ubuntu 19.10 or updates to it from last week?

Environment information:
Shotcut version 20.02.17, installed as a snap package, though I tried downloading the tarball and executing that, same issues, so it’s not confined to the snap package.

Shotcut Settings:
Video mode: Automatic
Display Mode: OpenGL
Operating System: Ubuntu 19.10 “eoan”

System Specifications:
CPU: Ryzen 9 3900X 12 core, 24 logical
Installed memory: 48GB
Available memory: 37GB
GPU: NVIDIA GTX1060, 3GB.

Thanks in advance for your time and assistance.

Looks like your audio device is busy. Did you try rebooting?

Yes, I have rebooted. Multiple times.

Here’s what happens when Shotcut tries to open audio in pavucontrol:

So, pulse is accepting the streams. But nothing plays. The rhythmbox stream at the top also does not play.

Other apps, like Chromium, can play audio, but their streams don’t appear in pavucontrol.
The Win10-2 VM you see in the background is configured to play through a pulseaudio sink, and that works as well, but doesn’t show up in pavucontrol.

Ok, found it.

The VM in the background sinks to the user’s pulse socket at /run/user/<uid>/pulse/native

Having the window open apparently locks that socket and nothing else can output via pulse.
Other items using ALSA (I guess? How does Chromium do its audio?) work. But pulse connected apps don’t.

Closing the virt-manager window unstuck everything.

Closing shotcut and re-opening the virt-manager window results in no sound from the VM.

Somebody really should rip the LInux sound infrastructure out root, tree, and branch. It’s unnecessarily complex. I can’t image what a pain it is for somebody to write for it.

Here’s a wrinkle:

Close all the pulse apps, kill gdm owned pulse daemon. Start it myself as a user proc (pulseaudio -D), everything works.

Here’s Shotcut, the VM, and Rhythmbox all playing sound simultaneously, and it’s mixing everything properly.

This post was flagged by the community and is temporarily hidden.