Shotcut stops on MAC when adding keyframe timeline

Shotcut version 19.12.16
MacOS High Sierra 10.13.6 / 8GM RAM

Last week I completed a 30 sec videoclip with Keyframes for moving and finished with export to MP4 file. For a new project I want to add keyframes to a clip, but when I press the Keyframe symbol Shotcut crashes immediately. I did some restarts and reinstalled Shotcut. When opening Shotcut without project and direct press the keyframe button, Shotcut crashes and shuts down without any warning.

When I open the finished project and press the Keyframe button Shotcut is stopping too. I tried the same project on a laptop and that seems to work well.

This is a part of the problem-report my Mac generates:

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x00000000000000c2 rbx: 0x0000000800082b02 rcx: 0x0000000000000000 rdx: 0x0000000000000003
rdi: 0x00007fa31b88c400 rsi: 0x0000000000000000 rbp: 0x00007ffee8788930 rsp: 0x00007ffee8788710
r8: 0x0000000000000000 r9: 0x0000000800082b02 r10: 0x0000000000000002 r11: 0x0000604000393300
r12: 0x00000000ffffffff r13: 0x0000000000000010 r14: 0x0000000800082b02 r15: 0x00007fa31b88c400
rip: 0x00007fff4e441527 rfl: 0x0000000000010203 cr2: 0x00000000000000c2

Logical CPU: 1
Error Code: 0x00000004
Trap Number: 14

A new version was just released a couple of days ago. Here is the link. Test on it to see if the issue still happens.

Deleted old version, including all system files for Shortcut. Installed version 19.12.31 but issue still happens when I press the Keyframe button direct when Shotcut opens.

Strange that it works perfect a few days ago on the same machine.

What model mac is this happening on?

iMac (27-inch, Mid 2010)
2,8 GHz Intel Core i5

I am not reproducing a problem on my 2 macs, but there are many places where a keyframe button appears. You need to be more specific. Is it next to a certain parameter of a certain filter? Is it on the main toolbar? Make a screenshot and highlight it please.

When I click on this Keyframes button in a empty project it shuts down direct.
But when using a filter and press the little keyframes button it happens too.

I switched to the Dutch language but still unable to reproduce it. It might be an OpenGL incompatibility on your system. But you can try deleting your settings plist file, which is at ~/Library/Preferences/com.meltytech.Shotcut.plist to see if it helps.

This file is not on my mac. I deleted it by removing version 19.12.16. I deleted old version, including all system files for Shortcut.

Look for that file again. I originally had an uppercase M where it should not.

42

I checked again, but it really is not there. Even not in the empty bin.
Watch screenshot to see the file is missing.

I got the same crash when selecting keyframes in Display menu (translate from french) and then moving the keyframes window (was completely black without icons). I finally found how to avoid it by not moving the keyframes window and then stopping Shotcut. After reopening Shotcut the keyframes window was with icons at the top. In this case I could move it without crash and insert it in the main window! [macOS 10.14.6 on a Mac Mini Late 2012]

It may have crashed because you were out of memory based upon what you may have been trying to edit. Just guessing here since there is no other information provided. The HDD (Hard Disk Drive) is a lot slower performance than an SSD or NVME could provide.
2020-01-08_14-17-21

My system is on a SSD with 16 GB RAM.

The 2012 mac mini was modular enough to upgrade(thankfully) so those base specs aren’t useful from a diagnostic point.

More likely is some form of driver problem around the gpu it seems to come up quite often looking up the error code provided earlier.

It worked for a while, so I think it s not a system issue. I think somewhere a corrupt driver could be the problem. But where to start to fix the problem…

Start with your graphics driver if you can.