Shotcut snap not working in Ubuntu 18.04


#1

I installed shotcut a few days back and it ran fine for one time I tried. However, it just fails to start now. To see the problem, I tried to start it from the terminal and got the following output:-

(process:3227): Gtk-WARNING **: 00:48:49.046: Locale not supported by C library.
	Using the fallback 'C' locale.
No appenders registered with logger
[Debug  ] <ShotcutSettings::singleton> language "en_IN" 
[Debug  ] <ShotcutSettings::singleton> deinterlacer "onefield" 
[Debug  ] <ShotcutSettings::singleton> external monitor "" 
[Debug  ] <ShotcutSettings::singleton> GPU processing false 
[Debug  ] <ShotcutSettings::singleton> interpolation "nearest" 
[Debug  ] <ShotcutSettings::singleton> video mode "" 
[Debug  ] <ShotcutSettings::singleton> realtime true 
[Info   ] <Application::Application> Starting Shotcut version 18.07.02 
[Info   ] <Application::Application> Linux version 
[Info   ] <Application::Application> number of logical cores = 12 
[Info   ] <Application::Application> locale = QLocale(English, Latin, India) 
[Info   ] <Application::Application> install dir = "/snap/shotcut/27/Shotcut.app/bin" 
[Info   ] <Application::Application> device pixel ratio = 1 
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[Warning] <> Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
[Debug  ] <MainWindow::changeTheme> begin 
[Debug  ] <MainWindow::changeTheme> end 
[Debug  ] <MainWindow::MainWindow> begin 
[Fatal  ] <> Could not initialize OpenGL
Aborted (core dumped)

After browsing around a bit, I found that it might be due to Nvidia drivers but couldn’t find any actual fix. So what should I do?
I am using Nvidia Drivers 390

My PC configs:-

  • CPU - Amd Ryzen 2600
  • GPU - GTX 1050Ti
  • OS - Ubuntu 18.04

Also glxgears runs fine.