Shotcut slows down with many clips in the video

Hello,

I’ve only been working with Shotcut for a short time and am pleasantly surprised at the range of functions. I am currently creating several tutorials in the field of measurement technology. There is a lot of text to integrate here.

Unfortunately, the more individual clips are inserted into the video, the slower the program becomes.

Example: Length of the videos: approx. 200 seconds

1 video track still image foreground
1 video track still image background
1 video track with 9 text clips with fades
1 video track with 9 text clips with fades
1 video track with 8 text clips with fades
1 video track with 3 text clips with fades
1 video track with 1 text clip with fades

The video opens normally with Shotcut.

And now the delays set in.
Calling up and executing all functions in Shotcut now takes an “eternity”, at least 5 to 8 seconds.
This also applies to saving processes and rendering (exporting).
Sometimes there is a message that the application has stopped responding.
In some cases the Shotcut program also crashed.

With regard to the hardware and software, everything is probably fine here.
My system:
CPU: Intel ® Core ™ i7-4820K, 3.7GHz
OS: 64-Windows 10 Prof. (20H2, current drivers) on SSD
RAM: 64 GB
HDD: 20 TB
Graphics: NVIDIA GeForce GTX 780 3GB RAM
ShotCut: Version 03/21/21

Strangely enough, this system runs with Shotcut in a virtual machine (VMWare-Player 15) with only 32 Gbytes of RAM without these delays in function calls and function executions!

Who knows this problem and has a solution?

With best regards from Germany und thank you
ringo1

You have a very good amount of ram, Even this much ram could run very heavy scenes in autodesk maya, I am not sure why it is happening to you but what I know is that you need to close all apps running in the background and turn on preview scaling with proxy clips, Closing all apps will not work in your case because this much ram could handle too much, I am sure that you will be having at least 4-6gb free even after opening 30-40 at once that means you have good amount of ram free, But proxy clips and preview scaling have 30% chances of working.

2 Likes

Maybe VMware is in partnership with Alienware :alien: and they both have sent their aliens :alien: to your physical PC to make shotcut not work on your PC but in the partnershipped VMware…LOL :rofl:

Some ideas to try in your Windows installation:

  • Try different options in Settings->Display Method
  • Disable “Show Video Waveforms” in the timeline options menu

Let us know if you see any difference with those settings. Maybe other people will have ideas to try also.

Thanks for your information. I followed all of your instructions, but the problem still exists.
Thanks anyway!

Unfortunately, the problem still persists. I’m also starting to believe in an alien conspiracy.
Thanks anyway!

Thanks for your information.

(1) Changes to the display mode in “Display Settings” did not result in any improvements.
(2) I deactivated the “Show video waveforms” option in the “Timeline options”. Unfortunately, the problem is still there.

I suspect that Shotcut might have fundamental difficulties calling the function routines in connection with a main memory larger than 64 GB.
Thank you for your efforts.