Shotcut slows and locks up entire computer when exporting project

I’ve got a project that I’ve been working on and when I try to export it as an MP4, it starts to lag and eventually the entire computer locks up.

I’m running the latest version (downloaded today) on Win10. I’ve got an i7-7820HQ processor at 2.90ghz with 16gb of RAM. I’ve got 278gb of free space on the internal drive and 3+tb free space on the external drive where I have all the video files. The video is 10 minutes.

How do I troubleshoot this? What should I look for? I’m afraid I don’t even know where to start to try and figure this out.

I just realized that, while I’ve rendered other projects successfully in the past (this one was just a couple of weeks ago), I haven’t tried another since this started happening. I’ll try that straight away and report back.

Thanks for any pointers that anyone can offer.

Update: I just exported two other projects, one of which was also 10 minutes (about 20 seconds longer even) and they worked fine. So it would seem that

I think most people who have experienced something like this, it is because they are low on memory for the Shotcut project. Then, the system ends up swapping memory with the hard drive like crazy.
If you reboot, immediately start Shotcut and nothing else, and immediately start export you give nearly all of your RAM to Shotcut. Or, if you feel more savvy, monitor your RAM usage and close other applications to free up memory.

@shotcut - Yeah, I was thinking that too, but I did exactly that – restarted the computer, didn’t run anything other than Shotcut, and it still locked up. It’s weird because I can tell it’s getting laggy because the mouse will stop responding, then move again, then stop… Eventually everything just comes to a complete halt. The mouse won’t respond, I can’t Ctrl-Alt-Del, nothing. Eventually the monitor just turns off and it’s done. Pressing on the keyboard triggers the backlight, though. It’s weird.

Is the project 4k? I can’t use my laptop(6700HQ, 32gb ram m1000m and dual 1tb nvme ssds+3.84tb sata) at all while it’s exporting 4k there’s just not enough resources to go around since it basically pegs the cpu.

You mention you have an external drive.
As it has +3TB space then I assume it is not a SSD.

Standard Disk drives are slow in computer processing terms.
If USB 2 then that will also slow it down.

Using a faster disk for the source and working area for shotcut may help.

I have a small USB3 Plug in SSD. (Standard USB disk, with a case from ebay)
I ran a utility that showed it was the fastest place for my video files to be during editing.

After editing, I can archive them to a normal disk.

Hope this helps.

@D_S - I don’t think it’s 4k; it was video shot on my cellphone (Samsung Note 9) using the standard camera app. (Other videos I’ve exported successfully – including the one I linked to earlier – were filmed on a 4k action camera (GoPro) knockoff, although I don’t know for sure if they were filmed in 4k.)

@Roger_Leitch - It is a traditional hard drive, but it is USB3 (with the double-wide connector) plugged into a “USB 3.1 Gen 1 Port with PowerShare”. I’ve not had problems using it previously. I can try moving everything to a different drive, but I don’t actually have an SSD I can use. I could try the internal drive which isn’t any faster, but at least wouldn’t be over USB. I kinda don’t think that’s the issue, though.

This video does have some text overlays (simple text filter on a transparent color) that are sized and positioned, as well as at least one image overlay. (By “overlay”, I mean on a second video track.)

Maybe what I need to do is create a new project and basically rebuild it? Maybe there’s something in the project that is hosing things? I was mucking around trying to figure out the picture-in-picture effect for the image overlay; maybe it got confused as I did that? I could also copy the project and take things out until it works?

The note 9 can/will shoot 4k so it’s entirely possible, shotcut could also be upscaling your output depending on your settings.

The HDD being slow could make the export slow but that would actually help here since the cpu would just be waiting for data.

The filters you used aren’t terrible sounding, can you upload the project(including the mlt file) to a folder somewhere so we can take a look at it?

@D_S – I can put the project on a google drive and share it – if you promise not to steal my ultra-lame unboxing video. lol.

I would need the mlt file and the image files included, right? Anything else?


@D_S – I forgot that when I first added the mp4 from the phone to the project, Shotcut converted it to a .mov. That file (the .mov) is 27gb! Could that be the problem? Do you need that file for troubleshooting?


No I can generate that, I’m going to guess that will take a while to upload. It sounds like it made it “edit friendly” IE constant framerate as opposed to VFR which is fine(I typically make my own files huffyuv although i’ve been experimenting with UTvideo) but could explain a slowdown on spinning media if that’s in use

@D_S – I’ve uploaded the project here:

I really appreciate your help!

So the good news is, nothing seems wrong with your project file, I had shotcut generate the mov and then was able to export it in 00:14:54 minutes on my laptop

The bad news there is it means one of two things, your mov file was corrupt somehow(since mine was generated although from the same source) or you have a system issue. I did note that although not 4k the video was shot in 2560x1440 certainly an odd setting.
Your system with the i7-7820HQ should have been faster than my i7-6700HQ but I am leveraging full ssd’s across the system(one sata 3.84tb and 2 NVME 1tb drives) it’s possible that the use of spinning disks is a bottleneck here.
For the sake of simplicity here’s the completed file

@D_S - Wow, thanks! So, if it turns out the .mov file was corrupt, could I delete it and have Shotcut regenerate it? Would it do that automatically or would I need to do something?

If it still has the problem, could it be bad memory? I would think that rendering would use up a lot of memory so it could be hitting a bad spot and that is causing the problem? But I generally have a lot of stuff open (when not rendering a video) so I would think the problem would have shown up before with other things?

Or could it be a bad hard drive? If it’s caching to disk, that might explain why I haven’t experienced this before. (But would it be the internal drive or the external one where all the files are?) I only use this external drive for video stuff (which I don’t do a lot of) so that would also explain why the problem hasn’t surfaced previously.

Anyway, I’ve grabbed the mp4 you created so you can delete it if you want.

Thank you so very, very much for your help! I really appreciate it!

Shotcut can re-create it, I did it just by opening shotcut and dragging the file into it, afterwards you can delete the original and drop it in place.

If you still have that problem a disk issue would be my first suspicion, you can check with a tool like crystal disk info what state your disk is in and if there are any re-allocated sectors.

As far as memory you’d typically see other system problems with a bad module, more wouldn’t hurt(I have 32 not 16) but shouldn’t be a factor for this task.

I’ll go ahead and remove that so someone doesn’t snag your unboxing!

@D_S – So I had Shotcut recreate the .mov file and it still crashed.

Okay, so I thought maybe it was the hard drive, like you said. So I moved everything onto the internal drive, disconnected the external one, and gave it another go. No go.

At this point, I was pretty stumped and was about to upload the version you did for me to YouTube when I noticed on the export tab, there was an option “use hardware encoder” that was checked. So I unchecked it and tried one last time. Voila! It worked!

So I don’t know why the hardware encoder was the problem, but going forward I’ll leave that unchecked.

Thanks again for your help!

Do you have a dGPU in the system or just the intel IGP it could be a codec conflict if it’s just the IGP and a codec that would have required an nvidia card for example(although I imagine shotcut would have displayed an error in that scenario) it would also explain why it worked fine on my laptop since there’s a quadro m2000 in it.

@D_S – I actually have a nvidia quadro m1200 with 4gb of memory. So maybe that board is failing? Oh well… Might be time for a new computer (though it’s only about 4 years old.)

I highly doubt there’s anything wrong with your gpu, you would be seeing many more issues and would’ve had problems exporting the projects that succeeded if there was. Quadro cards are made to be used hard for years , they have memory to correct for minor errors as well. That said Maxwell isn’t new I won’t tell you a new system wouldn’t be faster, especially a desktop.

This topic was automatically closed after 90 days. New replies are no longer allowed.