Shotcut resize/maximize when Timeline is showing

Using Shotcut 17.10, when I click the Timeline button, and the Timeline is displayed, the “Maximize” button disappears. It reappears when I close the Timeline or detach it from the main window.
I have reproduced this with the Snap and the .deb versions.

Hopefully an easy fix?

No, it is not an easy fix. There is no code directly in Shotcut that toggles the maximize button, and I do not reproduce it on Ubuntu 17.04 with Unity. More than likely, it is a weird interaction between the GUI library, your display driver, and your window manager.

Ah, well. I am running Ubuntu 17.10 (GNOME).
I can also reproduce it with Cinnamon desktop on a heavily customized Ubuntu 16.04.

Is there anything I can do on my end to get you more detailed output? I just tried starting shotcut from the command line and looking at the output, but nothing came up when I reproduced the issue.

You are referring to the correct thing? The maximize button that the window manger creates on the window title bar? I am not sure. You can post a screen shot.

Sure. Here you go.
Shotcut just opened:

Then just click Timeline on the toolbar:

And you see that the Maximize button (looks like “+” with my theme) disappears. If I close the Timeline and resize the window with the mouse, the Maximize button reappears.
It might be related to the way Shotcut seems to notify the Window Manager of minimum height allowed for the Shotcut window when the Timeline is displayed.

OK, at least we have a mutual understanding now. :slight_smile: strange. The height of the window can go down to 570 with timeline open for me.
Does the full screen button still work?

Yes, when it’s visible, it works. Maximize/unmaximize both work. But always without the timeline.

Something else to take into account: I have a 14inch 1920x1080 panel, so it’s HiDPI. I’m going to test reducing the resolution to 1366x768.

Ah, more clues: definitely related to resolution, not to Large Text (Accessibility setting).
I tried starting Shotcut at different resolutions.
The problem only happens at 1920x1080.
At 1680x1050 (the next lower resolution), the Maximize/Unmaximize button is always there, and works fine. The same for all lower resolutions.
Switching Large Text on or off makes no difference in the problem.

This is a behavior of Qt that I am not going to address, and it may get fixed when I upgrade Qt.

Totally understandable. Thanks for taking time to look into it.