Shotcut overwrites r/o projects

What is your operating system?
Linux Mint/Ubuntu 18.3

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
20.09.27 64bit

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
I created an empty .mlt file with some general settings for my wife. To make it messie-proof, I set it “read-only” with a file manager. The file icon got a lock symbol.
After that, I made some changes and clicked the “save” button. I expected a warning like “can not save, please save as another name” or something similar.
But instead of this, my .mlt file was overwritten. The “read-only” setting was removed from the file.

I just tested on Windows.
I saved a project, closed Shotcut and changed the attributes of the MLT file to read only.
I reloaded the file, made a modification but couldn’t save.


Did you get your copy of Shotcut from the official Shotcut website ?

Yes of course. And I think, “read only” works quite differently on Windows and Linux.

Perhaps it may work if I set the file “read only” as administrator instead of normal user. I will try this and report in a few hours.

What command did you use to make it readonly? Was it
chmod 0444 file.mlt

What does it show if you type:
ls -l file.mlt

I used the file explorer and changed permissions. But I can also open a terminal and use chmod, it does not matter.
I can set the file to 0444 or 0400 or 0777 or whatever - if I click the SAVE button, the permissions are always 0600 (= read+write)

This was fixed in version 20.10.31.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.