Shotcut overshooting cuts


I’ve been using Shotcut 17.04.02 on Linux Mint for a couple weeks, and I’ve been quite impressed by the simplicity and stability.

However, I bumped into a weird problem while editing a 720p 60 FPS GoPro video.

The speaker in the video says something like the following sentence –

“Here I am at the base of Mount Enormous, and I’m going to climb it.”

I created a cut after the words Mount Enormous, and smash cut (no transition) to a five-second still image of the mountain in question. In preview, it worked great. However, in the rendered MP4, things came out like this –

“Here I am at the base of Mount Enormous, and I’m…” [smash cut to image for five seconds] “…and I’m going to climb it.”

In summary, Shotcut is overshooting the intended cut, then returning from the cut where I intended (which actually creates a couple words of repeated footage). I found a forum post asking about a similar problem, and tried to export again using the GoPro footage’s exact FPS (59.940), but the problem persists. Aside from monkeying with FPS settings, all other export settings are Shotcut defaults for MP4 output.

The exact same thing happens later in the video when I attempt another smash cut away from the GoPro footage.

Any suggestions?


Unable to repeat this, are you using the audio track wave form to locate the exact point to slice?

If you mean visually using the audio waveform to pick the cut point, then yes. There’s a slight valley when the speaker (me) pauses after saying the name of the mountain, and that’s where I made my cut.

Even if the cut was slightly off, though (and in preview, it’s perfect), that doesn’t seem like it would explain the couple words of repeated footage that I mentioned.

Thanks for the response!

Hmmm. Odd.
If it’s cut at that point, previews fine and the trimming is removed, there’s no data to write I would have thought - especially if the preview is as intended.
But, I can’t repeat it here.