Shotcut no options for chroma key filter

HI there! I’m new to the forum (and relatively new to Shotcut), so please indicate if I did something wrong/didn’t include enough information.
I’m using version 21.03.21.

When applying the Chroma key: Simple filter, I do not get any options. Same for Chroma Key: Advanced. The tutorials I watched have these options, could anyone help? Sorry if this is just an update to Shotcut.

If it helps, I’m trying to greenscreen my outro into the video and although it has worked fine since there’s a little green outline that I’m DYING to get rid of and tutorials have options for that :confused:
Same for a call to action I’m trying to greenscreen, it has a green outline on the sides (although I might have made it too small [it’s meant to fill the entire screen at the bottom])

Could anyone help?

Hi @ThePhantomCoder
Can you provide a screen capture of the Shotcut window right after applying the Chroma Key filter ?

Try the Key Spill: Simple filter

1 Like

Hey @MusicalBox, adding the key spill: simple filter worked fine for my specific needs. However, there are still no options for the chroma key: simple filter and since I’m not aware if this is a bug or not, (and if other people might have the same problem) here’s a screenshot

It would help if you gave us information on the system you are running Shotcut on and where you downloaded Shotcut from. If you didn’t donload it from the official Shotcut website, then this could well be your problem as was the case here:

I’m running Shotcut version 21.03.21 on Windows 10 64 bit. I have not downloaded Shotcut from the official website. I used to get a portable version since I do not have administrator permissions to this computer.

And wouldn’t the official portable version work on your computer?

1 Like

I’m pretty sure that this is your problem. As @ejmillan points out, you can get a portable version from the official Shotcut website. I’m 99% certain that will fix your problem.

I think the install is based on our build, but there could be something going on specific to that or at least specific to that on your machine. See also Settings > Display Method

Thanks! I was not aware Shotcut had an official portable version and it solved my problem

1 Like

As one of the developers over at, I can confirm that our package is indeed based off the official portable build, Dan, with our package using built-in command line settings to change the appdata directory and adjusting paths like our other applications. See here for what we do: AppConfigs/S/Shotcut at master · PortableApps/AppConfigs · GitHub

1 Like

@ThePhantomCoder, I’d love to solve your problem with the package, feel free to send me a direct message here or get in touch at for further investigation.

This topic was automatically closed after 90 days. New replies are no longer allowed.