Shotcut loses MLT file after crash

I was just working on a project and Shotcut locked up and crashed. The MLT file, which I had been routinely saving, just disappeared. I have been opening it up from the same location and it had been open in the application for days (working on it in between other work tasks). I opened the window, and started editing and noticed a video fade-in/fade-out on a transparent text-only video layer (use for captioning videos) was not working in the preview. Having experienced issues that fix themselves after shutting down and starting again, I decided to try that. So, I saved and shut down. I re-opened the file to start working on it again. After a couple of splits and edits, it locked up and crashed. However, this time when I went to the folder the project file was located, it was gone. I did a search of my computer for the file, but nothing. HELP!! I have a couple weeks of work into this project and I was already behind.

Shotcut version 18.08.01

1 Like

While developing on Shotcut, I have experienced numerous crashes, often times trying to reproduce other people’s crashes to debug them. However, I never experienced the loss of the .mlt file, but I suppose it is possible. I am sorry to hear about your loss. There might be an auto-save copy of the file:

  1. In the main menu, choose Settings > App Data Directory > Show…
  2. Open the autosave folder in your file manager and look for the most recently modified file.
  3. Copy the most recent file somewhere and change its name.
  4. Try to open the copied file in Shotcut.
  5. Is that the project you lost?
  6. If not, maybe repeat this with the second-most recently modified file. It depends on if you opened other projects or made something you did not save.

In the end, if you do not have a backup system in place your work might be lost forever.

1 Like

Thank you!!! I found it that way. I am copying a file to another folder to keep this from happening again. It literally had the exact moment of the crash saved. PERFECT!

Wow. I am very glad that worked out for you!

Got the same problem on a file I was working with for almost 1week.

@shotcut your method just worked !!! I’m so fresh now, thanks !!