Shotcut is unresponsive on new PC

I’ve been using Shotcut for ages without problems and never have needed to look for help on the forums till now.

So here is my issue:

While only loading one source video that was already previously encoded with Shotcut using my previous computer(1080p 17 minutes used YouTube preset).

The software runs incredibly slow, becomes unresponsive, and I have to force shutdown. I tried two versions of Shotcut (noted below) and they both do the same thing. I tried the regular installer and the portable versions. It seems like the portable versions work better for some reason.

Things I noted:

  1. Program runs fine without NOTHING loaded. As soon as you put one single source video Shotcut begins to crawl until it stops.

  2. The few times it worked as intended as soon as I would try to save the project it would come to a crawl. Closing and reopening would speed it up but as soon as I opened the project, which had no edits just the source file, the program took a whopping 10 minutes to open it and then was unusuable. These videos along with the uncompressed original sources would not slow down my older PCs even without using proxies and having multiple sources like the gameplay, camera, separate audio sources, effects, filters and they would open right away without a hitch and editing would be quick and painless.

  3. The way I can tell right away when Shotcut is going to have issues is by mousing over the top bar panel File, Edit, View, Settings. Normally choosing those works like a charm with this computer the context menus take forever to load.

  4. I’ve tried changing display methods from Auto, OpenGL, DirectX, Mesa. Mesa seems to work best for some reason.

  5. Nvidia GeForce experience thinks Shotcut projects are games: I open Shotcut, nothing is loaded, the sofware runs fine. I open a previous MLT file, Nvidia GE overlay starts and the program begins to run incredibly slow. I have since disabled GeForce experience and this seemed to be the remedy. Shotcut ran fine, I edited with no problems, zero slowdown, menus work, it encoded in less than half the time as my previous computer.

I thought I had solved the issue, but now the problem appears randomly. If I open a project and it just starts to hang I just close the program. I then restart the PC and the open Shotcut.

If it works fine upon opening then I will be able to Edit, choose options in menu, add fiters, Save, export without a single issue. But if I close the program and restart it usually goes back to being unusable unless I also restart the PC.

Again my previous computers which are much older never had these issues.

I have included the log and did notice a couple things that stood out:
[Warning] [consumer 0x25e3c3b4aa0] The DeckLink drivers not installed.

I’m not sure what DeckLink is and if I need these drivers but a Google search only resulted with Davinci resolve needing these drivers and not where to get them and what they are for.

[Debug ] ShotcutSettings::log GPU processing false

My understanding is that Shotcut is not GPU dependent and also I’ve selected each different option in Display and none remedy the problem.

My new PC Specs:


CPU: AMD Ryzen 5 5000 Series 5600G 6-Core 12 Thread Processor 3.9 gigahertz (19,848 passmark)

RAM: 8 GB x1 DDR4 3200 megahertz (has four slots supports up to 128GB)

GPU: NVIDIA GeForce GTX 1660 SUPER 6GB Memory

Storage: 512GB SSD Primary

Secondary Drive: 4TB I installed from previous Lenovo Desktop.

Windows 11 Home

Old computers running Shotcut just fine:

Old Desktop Specs:

Lenovo Desktop

CPU: i3 6100 3.7GHz (4,154 passmark)

Ram: 8GB


Hard drive: 512GB and 4TB secondary that is now in NEW PC

Windows 10 Pro

HP Pavillion Gaming Laptop specs:

CPU: i5-8300H 8th gen (7,512 passmark)

Ram: 8GB DDR4

GPU: GTX 1050ti 4GB GDDR5

Windows 10 Home

ShotCut versions Tested:
22.03.30 This is the same version I had in my previous desktop and my Laptop

22.12.21 Also tested this version

Any help is appreciated. Unfortunately, I did not test Shotcut on my new PC earlier and I’m now past the point that I may exchange it.

TheThief Shotcut Log.txt (296.8 KB)

This sounds similar to problems that some other people have when they have a software compatibility problem. Often, the advice is to disable any software that might interfere with Shotcut. For example, as a test you could disable any antivirus applications. Also, Grammarly is known to interfere with Shotcut.

1 Like

This seems to be related or the same

No developer has reproduced a problem including myself. My Windows 11 dev system is similar to yours:

  • Ryzen 5600G
  • 32 GB RAM
  • NVIDIA GeForce RTX 3060
  • SSD main drive

Only time I had a problem that was similar to the problem reports was when Windows Update was upgrading in the background. When you experience the problem, check if Windows Update is applying an update or a restart is pending. If so, then reboot when it is ready. Still, I would not be surprised (from being exposed to all sorts of oddities reported by millions of downloads of Shotcut over 10 years) if there was something going on in the software that is only triggered under certain, unknown factors - probably not due to hardware but software such as driver or system extension.

Thanks for the replies. My thought was that it was likely some compatibility issue with Windows 11 and specific drivers. I’ll make sure everything is up to date. I have been uninstalling some bloatware and disabling programs that might interfere. Glad I’m not the only one with issues on Win 11.

My old PCs work just fine but I thought it was time to upgrade. I’ve been having a hell of a time with new PCs. Two previous ones had major issues on first run. One would overheat as soon as Windows loaded, fans would kick on high gear and then the PC would go kaput.

Thanks, I’m hoping finishing Windows updates will resolve the issue.

I would like to have the solution to the problem. Shotcut just doesn’t work with Windows 11 on my computer. I have followed all the recommended steps without getting a solution.
Initially the operating system was Windows 10, where Shotcut worked perfectly, but after upgrading to Windows 11 the application did not work. I keep the problem hoping that “God listens to me and the Devil turns deaf” and this difficulty is solved and some expert or developer will have mercy on those in need.

We’re working currently on a major upgrade of one of our main libraries, Qt, that will also switch to using Direct3D on Windows instead of OpenGL. I hope these two big changes will remedy this problem some people are experiencing. Keep an eye out for the beta hopefully by very early February.

1 Like

Looking forward to it. Thanks!

Update: After allowing Windows to install all pending updates Shotcut works pretty flawlessly. Thanks for the suggestion.

I look forward to trying the beta version.

This topic was automatically closed after 90 days. New replies are no longer allowed.