Shotcut is maxing out my 16GB RAM and freezing

I have a pretty good laptop with 16GB RAM that should NOT be freezing after trying to fade in audio, or scrolling, or doing literally anything when I have only 2 tracks and a 1080p video.

I checked Task Manager and apparently Shotcut is using 11.5GB of my RAM, which is going up to 97%. CPU is no more than 30%. There is absolutely no reason for it to need 11GB RAM when I’m just importing a 500MB video file.

What should I do?

I think you are correct it should probably not be using that much memory. It is not normal, but something very specific that you did probably triggered a memory leak. However, we do not know what that is. Do you? Can identify the exact steps or combination of things that caused it?

Thank you for the quick response. I did nothing out of the ordinary, but I should note that the insane RAM usage was only noticed today. I hadn’t checked task manager all the other (very frequent) times that Shotcut lagged/froze. It likely is the same problem but I’m not sure.

What I did was import a 500MB mp4, import a 54MB WAV file (both drag&drop), add a fade in for both and cut a bit of the beginning. Even while trying to fade in and cut, it was unbearably slow until I eventually pressed play and zoomed out and it froze for minutes.

Right now it’s at 5.3GB RAM usage. Less but still abnormal.

I’ll be happy to give any additional info, sorry for not knowing straight up what to include.

What is your operating system and Shotcut version?
How long in time is the timeline after you add these two files?

Windows 10 x64. I can’t check my version because it’s still frozen but it’s no more than a week old.

For another example, even just switching to Audio view freezes and sometimes crashes Shotcut before I do anything in it.

And I can now confirm it’s still stupidly slow even without the memory leak (550MB RAM right now).

Then, I guess it simply does not work good on your computer for whatever reason. You can try the different options in Settings > Display Method. I am sorry I will be unable to help further.

Actually it seems it’s running much better now after using the OpenGL setting, thank you! It’s at least comfortably usable now, despite Audio view still crashing every time. I suspected it had to do with rendering method.

Thanks again.

1 Like

You should also ensure you only have one shotcut.exe in the Task Manager Details view. It does not run well with more than one even if one is hung in the background. Also, when first importing a long clip with audio please allow time for the waveform generation running in the background. That adds activity that can make it feel slower.

Niether of these apply to me but as I said, setting to OpenGL made things much better and I was able to finish the (very simple) tasks I needed.

Actually although it’s at least usable now, it’s still Not Responding quite frequently and being quite slow so if anyone has any other suggestions they’re welcome.

Last update: it seems after I reset my PC my GPU settings weren’t completely restored and Shotcut wasn’t fully using my dedicated NVIDIA GPU.

So along with the suggestion to switch Display Method to OpenGL, what fully fixed my problem seems to be setting Shotcut to High Performance preference in Windows Graphics settings. Oops.

That is interesting. Shotcut contains codes for Windows that is supposed to select the first discrete NVIDIA or AMD GPU. I think Task Manager can report about this in the GPU engine column:

To access what @l.madanat is talking about, press the Window key or click WIndows Start and type in “graphics” to access Graphics settings

1 Like

Exactly, thanks for the screenshots. This is exactly what confused me as well - task manager DID show GPU 1 (NVIDIA dGPU) as being used by Shotcut. Maybe it was doing some sort of hybrid usage before I forced the option in settings? Either way this is what fixed it for me!