Shotcut is Crashing - CTRL+Z/Y in Keyframes Window

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
The latest version. No 64-bit

Can you repeat the problem? If so, what are the steps?
I opened up the keyframes tab.
And I can’t undo the changes. Okay.
But instead, the undo happens to the timeline.
And when I control Y the undos, it crashes.
Doesn’t even stop responding.
Just closes.
Please help me :slight_smile :frowning:

Please give the actual version number.

Also, your steps are too vague. Please be more specific with steps that someone else can follow in order to try and reproduce on their end your issue.

20.11.28 is the version.

And the exact steps :-
0) Create a filter

  1. And keyframe the filter.
  2. Change something in keyframes.
  3. Then control z or undo repeatedly
  4. Then control y repeatedly.
    This is how it crashed for me.

CTRL + Z doesn’t work for undoing keyframes.

You can do this to get rid of all keyframes. This keeps the filter, just deletes all keyframs.

Or you can do this for one keyframe at a time. Use the seek icons there to move between each keyframe.

Yes! I realized it and I have also said it in the post.
It instead undos the timeline.
It would be helpful if you could tell me how I CAN do it.

I have said it here:-

I modified my post above to help you further with removing keyframes. :slight_smile:

@shotcut Could you add some sort of warning when using CTRL+Z in this situation. Or disable CTRL+Z if focused on Keyframes tab/window. I’ve made this CTRL+Z mistake countless times myself.

OR better yet, make it control-z a feature!

I didn’t quite get this method



1 Like

Keyframes stems from filters, and undo/redo support for filters is not implemented and on the road map.

I would be great if you could implement it! :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.