Shotcut incompatible Windows 11

Windows 11, actualizado de windows 11

Shotcut versión 22.12.21, 64 bit

Shotcut is not responding while loading any video.
I have reinstalled Shotcut several times, it works fine the first time, but not when used a second time. Shotcut crashes and then starts consuming memory rapidly.
With previous windows 10 it works perfectly.
I ran compatibility tests and the results indicated that Shotcut was incompatible.
I use this app all the time to prepare small clips for my classes.
I need tips.
Thank you.
shotcut-log.txt (71.5 KB)

Try changing your Display Method in the Settings Menu, say to DirectX (ANGLE) and see if that works.

Hello. I have used all display methods. It does not work.

Sorry, this version works without any issues on my Windows 11 system, so I don’t know what else to suggest.

Thank you for your concern. It seems to be a very difficult topic to resolve. I have searched a lot for information on the internet and no answers can be found.
I don’t know if the developers of the program have said anything, however, I see zero concern from those of us who ask about this.
Shotcut is an excellent program and I use it quite successfully in preparing my themes. I’m sorry I can’t do it now on my PC with more capacity. Luckily I have another one with Windows 10, but it is very slow.
I repeat thank you for your effort.

There were some momory leaks fixed in the latest version, but it appears you are already running that version. see here:

It might be worth reverting to the 22.10.25 version and see if that works for you.

Thanks for your reply - happy holidays!

My problems running Shotcut started with version 22.10.25 - which came out the same time my Windows 10 machine decided to upgrade itself to Windows 11 Pro. (That happened when I got a cheap TPM daughter board and plugged it into my old motherboard - but that’s another story).

Although version 22.12 was able to process one of the small test input files (that had previously made Shotcut go nuts consuming memory) o.k., it wasn’t successful at importing a longer (90 minute, 1080x1920) video file - apparently going into a memory consumption loop a few minutes after trying to import the file. So even though they found and fixed some memory leaks, it doesn’t solve this problem for me. Still unknown is why and what Windows 11 may be doing to cause this. Note from the discussions above, nothing really wrong with my hardware configuration - every other video editor I run the same inputs through handles them just fine - and everything else I run on the machine works perfectly, as expected.

I’ve tried going back to several older versions of Shotcut too, but with Windows 11 all of them had the same memory consumption issue that version 22.10.25 and now 22.12 had.

So I’ll hope that they can find some more memory leaks in Shotcut in the future and fix them, since something weird is still going on with these simple file imports to send it into a tail spin on my machine.

Hello. That is exactly what happens to me too. I hope this situation can be resolved.

When you say you have reinstalled several times, have you followed this process to the letter (including registry cleaning and manual folder search and removal)?

If not then that is the first thing to try. Also, do you by chance use grammarly?

Hello. I used Windows uninstaller, ran CCleaner to clean the registry. I don’t know any other method, because I’m not a computer technician. There are probably other methods, but that’s what I’ve done.
I don’t speak English well, I use Google Translate to formulate my queries.

Shotcut has also been working well for me on Windows 11.

I have two suggesions similar ot @PoisonedSlice:

  1. Reinstall Shotcut and be sure to check the option to remove registry settings:


  1. Make sure that you do not have Grammarly installed. If it is installed, uninstall it. This program has been known to interfere with Shotcut.

Thanks for taking an interest in my case. When installing the application if I check the option to delete the registry settings.
I don’t use Grammarly.
Before posting to the forum, I read the answers I found and took the suggested actions. However, since I couldn’t fix the problem, I made the query in case there was something else. I have not solved the problem.

Well it looks like you’ve taken the generally accepted correct course of action, so good work! I would however encourage you to try uninstalling once more while making sure to manually remove the folders in my link above before doing the reinstall (that folder removal is significant and has helped solve more than one issue).

CCleaner used to be a fantastic piece of software, but imo ever since Avast bought them out things have taken a turn for the worse, and I personally remove it from every windows machine I work on. As an FYI:

This bug (for which there is no solution) is now being tracked in GitHub

Do we just wait?

The problem is that the developers do not experience this issue. So we can not fix it. The best thing we can do is try to provide simple instructions on how to reproduce the issue.

Did you check in the computer settings to make sure it is not installed?

Aplicaciones.txt (10.2 KB)

On very rare occasions, as in the one I linked, this is not enough and you need to manually remove folders. So I will ask again - have you uninstalled and reinstalled following this exact process, including manual folder deletion?

If not, then you please do that first since it is relatively quick and easy.