Shotcut "Image Sequence" will not load a full folder of images


#1

Blockquote

I made a couple time lapses a month ago using the image sequence feature. It was buggy but I could eventually get it to load whole image folders. I believe since then upgraded to new version of Shotcut. I would like to make two more time lapses but now I can not ever get the folders to load, they only partially load, either about 1/32 or 1/8 of the file folder of anywhere between 800 photos and 1500. The two lapses I originally got to work used 1000 to 2500 images. Ive tried converted the Jpgs to Pngs but to no avail. The original lapses that worked I used Jpgs.


#2

This seems to function Randomly, personally I’ve never had success with the feature.
In the meantime, try MakeAVI, it’s free and flawless.


#3

What is the naming format of your images. It is very important that the image names be continuous.


#4

I’m having this same problem. My folder has 240 PNG images. At first, they were named 0001.png, 0002.png, etc. then I tried changing that to: character_ball_001.png, etc.

All 240 images make it into the viewer and from there, onto the timeline. But outputting from either the timeline or the playlist, only 229 images are converted into frames in the video output.

So, other than naming conventions, do you have any other suggestions?


#5

See post 2 or use VitualDub.


#6

How can you tell the number of pictures that is converted? Did you calculate from the duration of the video?

Are you sure the video has the frame rate which you expect it to have?

What are the last 20 files’ filenames? Perhaps there is a gap?

I created a 2000 192x108 png animation for testing purposes: https://mega.nz/#!uCpmXJqS!gyB97rp7yATo1HZqlihoZmQyhKHpt2sP_PJ6B0LlRKQ

It seems to import fine for me. I just had to re-resize the clip a few times.


#7

Resize the clip? In the timeline or the viewer? How do you resize it? I thought it was automatically set to whatever length was appropriate for the number of frames?

I ask because I suspect it’s got something to do with using a 24fps preset. Whenever I click on Properties > Image Sequence, the Export Frame/sec box goes back to 25fps. I reselect my 24fps preset again before exporting.

The clip is 9:14 in length and when I look at the difference in frame count between 24fps and 25, it’s the number of missing frames.


#8

What is that? Choose something in Settings > Video Mode other than Automatic and start a new project. If you use Automatic, then something unexpected might be happening. If you start a project using Automatic using something other than a video clip, then it defaults to 1080p25, which sounds like what you are experiencing.


#9

That did the trick. Thanks, shotcut leader. :slight_smile: