Shotcut frequently crashes - GNU/Linux Debian 12

Hello everyone :slightly_smiling_face:

I created a new topic because I could only find Windows crashes, not on Linux Debian. Feel free to tell me if this topic’s a duplicate.

What is your operating system?

Debian GNU/Linux bookworm/sid

That’s Debian 12 “unstable”. (despite the name, it is surprisingly stable and I never had major bugs with it)

What is your Shotcut version (see Help > About Shotcut)?

Shotcut version 21.12.22, installed from the official Debian GNU/Linux “deb” repository

Can you repeat the problem? If so, what are the steps?

Yesterday it crashed ~5 times randomly but it was OK after reopening, today it crashes every time I try to add a transparent clip into my project.

  1. I open an existing project with 3 video tracks.
  2. File > Open other > Generator > Colour > transparent > OK
  3. A preview of the generated clip appears.
  4. I can drag this preview but I soon as I release it Shotcut crashes. If I move the playhead to any position in the timeline Shotcut crashes too.

Just before releasing the mouse:


  • I have been using Flathub’s version of Shotcut before and rarely got problems.
  • Since I uninstalled and installed Debian’s official version, Shotcut doesn’t detect any hardware encoder whereas it was detecting QSV before.
  • I have a dual boot on Windows and Shotcut does detect QSV there.

Are crashes happening because I tampered with different Shotcut versions?
Am I missing a dependency?

I would greatly appreciate your help on this issue :slightly_smiling_face:
I can uninstall + reinstall Shotcut if needed.

Thanks, wishing you happy holidays :yum: :christmas_tree:

What video mode/video resolution do you have it on? Try it again with a new project changing the video mode to different video resolutions to see if it still crashes.
Does it only happen with a transparent clip?
Does it still happen if you change the transparent clip to a color clip?
Also, there is a 21.12.24 version that got released on the Downloads page up on top of this page. Download it and see if it also happens on that one.

1 Like

I do not make that build.

The problem you describe is frequently reported, and I believe it may be because the frei0r-plugins package is not installed. Shotcut requires that, but we do not maintain the Debian shotcut package to list it as a dependency. Also, everyone I have suggested to check this has never replied to confirm. It would be good for us and every Debian package user to know.

Since I uninstalled and installed Debian’s official version, Shotcut doesn’t detect any hardware encoder whereas it was detecting QSV before.

The build of FFmpeg must enable support for VAAPI, and I bet it is not. This is not something we can control since we do not make the package.

1 Like

Thanks for your help people :slightly_smiling_face:
I’m going to follow @shotcut 's message.

I do not make that build.

Oh! So for Linux users, do you recommend installing the Flathub version?

It would be good for us and every Debian package user to know.

Of course I’ll give you the answer… in the name of LEARNING! :laughing:

Package is installed boss:

PrSunflower@PC:~$ sudo apt list --installed | grep -i frei0r-plugins

frei0r-plugins/unstable,now 1.7.0-2 amd64 [installed,automatic]

The build of FFmpeg must enable support for VAAPI, and I bet it is not.

Hey you’re reminding me of something. I had to install ffmpeg separately, I found it somewhere on the forum and I noticed it wasn’t installed on my computer so I installed it manually:

ffmpeg/unstable,now 7:4.4.1-2+b1 amd64 [installed]

How to reinstall the propoer way?

This is not something we can control since we do not make the package.

Yeah no worries I was having a strong feeling I should not use this version of Shotcut. :slightly_smiling_face:

What is the “cleanest” way of uninstalling Shotcut on Linux? Will sudo apt purge shotcut + a reboot do the job?

In that case the most likely problem is a build compatibility mismatch between MLT and FFmpeg. In our builds we take care of that by bundling most dependent libraries except some low level ones.

1 Like

Pardon me for jumping into the middle of this but with a dual boot Windows/Linux machine, why are you running Shotcut on Linux? Do you see a performance improvement on Linux or is this your preferred OS for most everything else?

This is precisely why I am an “AppImage and done” person on Linux. Is there a reason (to the OP) that you prefer a Debian repository version rather than AppImage or the tar archive? Genuine question in the hopes of hearing an interesting answer… not trying to give you a hard time.

Hi Happy New Year 2022! :partying_face: :sparkler: :sparkles: :star2:

That’s cool to see curious people on the thread :grin:

In our builds we take care of that by bundling most dependent libraries except some low level ones.

Understood thank you for being so careful :slightly_smiling_face: I’ll switch back to the Flathub version and tell you how it goes.

with a dual boot Windows/Linux machine, why are you running Shotcut on Linux? Do you see a performance improvement on Linux or is this your preferred OS for most everything else?

Both! :open_mouth:

  • I am trying to use as much free software as possible so my Debian is my preferred choice.
  • With the Flathub version I was indeed seeing small improvements compared to the same version number on Windows 10. I haven’t had major bugs with either OSes but the small “freezes” which occurred on Shotcut Windows did not occur on Shotcut Linux.

Is there a reason (to the OP) that you prefer a Debian repository version rather than AppImage or the tar archive?

I appreciate the politeness in your question :slightly_smiling_face:

Nothing factual. I was wondering if it would be “cleaner” to install as most software as possible from the official repos of my distro instead of Flathub.

Also, I think I can only do updates from the terminal, (sudo apt update && sudo apt upgrade) because the Software Store which worked fine on Debian Stable tells me “Cannot update xyz because dependencies haven’t been met.” since I am on Debian Unstable.

Because of this I have to do a second command to update Flathub stuff: sudo flatpak update, which I was hoping I didn’t need to do if I was running the Debian build of Shotcut.

Thanks for everything people, I’ll try the Flathub build of Shotcut. :v:

Hello @shotcut , hope you’re well.

I uninstalled my previous version and installed the Flathub version of Shotcut.

I am currently running Shotcut 21.12.24 but it refuses to open :frowning_face:
I see the splash screen for some seconds then it disappears and nothing happens.

Could you please assist me?
Launching it from the terminal, here are the outputs:

user@PC:~$ flatpak run org.shotcut.Shotcut
Gtk-Message: 19:14:01.399: Failed to load module "canberra-gtk-module"
Gtk-Message: 19:14:01.399: Failed to load module "canberra-gtk-module"
[Info   ] <Application::Application> Starting Shotcut version 21.12.24 
[Info   ] <Application::Application> Linux version 
[Info   ] <Application::Application> number of logical cores = 4 
[Info   ] <Application::Application> locale = QLocale(English, Latin, United Kingdom) 
[Info   ] <Application::Application> install dir = "/app/bin" 
[Debug  ] <ShotcutSettings::log> language "en_GB" 
[Debug  ] <ShotcutSettings::log> deinterlacer "onefield" 
[Debug  ] <ShotcutSettings::log> external monitor "" 
[Debug  ] <ShotcutSettings::log> GPU processing false 
[Debug  ] <ShotcutSettings::log> interpolation "nearest" 
[Debug  ] <ShotcutSettings::log> video mode "" 
[Debug  ] <ShotcutSettings::log> realtime true 
[Debug  ] <ShotcutSettings::log> audio channels 2 
[Debug  ] <MainWindow::changeTheme> begin 
[Debug  ] <MainWindow::MainWindow> begin 
[Info   ] <MainWindow::MainWindow> device pixel ratio = 1 
[Info   ] <GLTestWidget::GLTestWidget> OpenGL context version 3 0 
[Debug  ] <Mlt::Controller::Controller> begin 
[Info   ] <Mlt::Controller::resetLocale> decimal point . 
[Debug  ] <Mlt::Controller::Controller> end 
[Debug  ] <Mlt::GLWidget::GLWidget> begin 
[Debug  ] <Mlt::GLWidget::GLWidget> end 
[Debug  ] <MainWindow::setupSettingsMenu> begin cannot open shared object file: No such file or directory
[Warning] <MLT> [consumer 0x557f9ebfed30] The DeckLink drivers not installed.
[Debug  ] <MainWindow::setupSettingsMenu> end 
[Debug  ] <MainWindow::readPlayerSettings> begin 
[Debug  ] <MainWindow::setAudioChannels> 2 
[Debug  ] <Mlt::Controller::setAudioChannels> 2 
[Debug  ] <MainWindow::setPreviewScale> 360 
[Debug  ] <Mlt::Controller::setPreviewScale> 450 x 360 
[Debug  ] <MainWindow::readPlayerSettings> end 
[Debug  ] <MainWindow::configureVideoWidget> begin 
[Debug  ] <MainWindow::setProfile> "" 
[Debug  ] <Mlt::Controller::setProfile> setting to profile "Automatic" 
[Debug  ] <MainWindow::setAudioChannels> 2 
[Debug  ] <Mlt::Controller::setAudioChannels> 2 
[Debug  ] <MainWindow::configureVideoWidget> end 
[Debug  ] <ScopeController::ScopeController> begin 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget> begin 
[Debug  ] <AudioLoudnessScopeWidget::AudioLoudnessScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget> begin 
[Debug  ] <AudioPeakMeterScopeWidget::AudioPeakMeterScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget> begin 
[Debug  ] <AudioSpectrumScopeWidget::AudioSpectrumScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget> begin 
[Debug  ] <AudioWaveformScopeWidget::AudioWaveformScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoHistogramScopeWidget::VideoHistogramScopeWidget> begin 
[Debug  ] <VideoHistogramScopeWidget::VideoHistogramScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoRgbParadeScopeWidget::VideoRgbParadeScopeWidget> begin 
[Debug  ] <VideoRgbParadeScopeWidget::VideoRgbParadeScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoRgbWaveformScopeWidget::VideoRgbWaveformScopeWidget> begin 
[Debug  ] <VideoRgbWaveformScopeWidget::VideoRgbWaveformScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoVectorScopeWidget::VideoVectorScopeWidget> begin 
[Debug  ] <VideoVectorScopeWidget::profileChanged> 709 
[Debug  ] <VideoVectorScopeWidget::VideoVectorScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoWaveformScopeWidget::VideoWaveformScopeWidget> begin 
[Debug  ] <VideoWaveformScopeWidget::VideoWaveformScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeWidget::ScopeWidget> begin true 
[Debug  ] <ScopeWidget::ScopeWidget> end 
[Debug  ] <VideoZoomWidget::VideoZoomWidget> begin 
[Debug  ] <VideoZoomWidget::VideoZoomWidget> end 
[Debug  ] <VideoZoomScopeWidget::VideoZoomScopeWidget> begin 
[Debug  ] <VideoZoomScopeWidget::VideoZoomScopeWidget> end 
[Debug  ] <ScopeDock::ScopeDock> begin 
[Debug  ] <ScopeDock::ScopeDock> end 
[Debug  ] <ScopeController::ScopeController> end 
[Debug  ] <RecentDock::RecentDock> begin 
[Debug  ] <RecentDock::RecentDock> end 
[Debug  ] <PlaylistDock::PlaylistDock> begin 
[Debug  ] <PlaylistDock::PlaylistDock> end 
[Debug  ] <TimelineDock::TimelineDock> begin 
[Debug  ] <TimelineDock::TimelineDock> end 
[Debug  ] <FiltersDock::FiltersDock> begin 
[Debug  ] <FiltersDock::FiltersDock> end 
[Debug  ] <MarkersDock::MarkersDock> begin 
[Debug  ] <MarkersDock::MarkersDock> end 
[Debug  ] <KeyframesDock::KeyframesDock> begin 
[Debug  ] <KeyframesDock::KeyframesDock> end 
[Debug  ] <EncodeDock::EncodeDock> begin 
  - a64
  - ac3
  - adts
  - adx
  - aiff
  - alp
  - amr
  - amv
  - apm
  - apng
  - aptx
  - aptx_hd
  - argo_asf
  - asf
  - ass
  - ast
  - asf_stream
  - au
  - avi
  - avm2
  - avs2
  - bit
  - caf
  - cavsvideo
  - codec2
  - codec2raw
  - crc
  - dash
  - data
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - f4v
  - ffmetadata
  - fifo
  - fifo_test
  - filmstrip
  - fits
  - flac
  - flv
  - framecrc
  - framehash
  - framemd5
  - g722
  - g723_1
  - g726
  - g726le
  - gif
  - gsm
  - gxf
  - h261
  - h263
  - h264
  - hash
  - hds
  - hevc
  - hls
  - ico
  - ilbc
  - image2
  - image2pipe
  - ipod
  - ircam
  - ismv
  - ivf
  - jacosub
  - kvag
  - latm
  - lrc
  - m4v
  - md5
  - matroska
  - matroska
  - microdvd
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - mxf_opatom
  - null
  - nut
  - oga
  - ogg
  - ogv
  - oma
  - opus
  - alaw
  - mulaw
  - vidc
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - roq
  - rso
  - rtp
  - rtp_mpegts
  - rtsp
  - sap
  - sbc
  - scc
  - film_cpk
  - segment
  - stream_segment,ssegment
  - singlejpeg
  - smjpeg
  - smoothstreaming
  - sox
  - spx
  - spdif
  - srt
  - streamhash
  - sup
  - swf
  - tee
  - 3g2
  - 3gp
  - mkvtimestamp_v2
  - truehd
  - tta
  - ttml
  - uncodedframecrc
  - vc1
  - vc1test
  - voc
  - w64
  - wav
  - webm
  - webm_dash_manifest
  - webm_chunk
  - webp
  - webvtt
  - wtv
  - wv
  - yuv4mpegpipe
  - fbdev
  - oss
  - pulse
  - sdl,sdl2
  - video4linux2,v4l2
  - xv
  - comfortnoise
  - s302m
  - aac
  - ac3
  - ac3_fixed
  - alac
  - aptx
  - aptx_hd
  - dca
  - eac3
  - flac
  - g723_1
  - mlp
  - mp2
  - mp2fixed
  - nellymoser
  - opus
  - real_144
  - sbc
  - sonic
  - sonicls
  - truehd
  - tta
  - vorbis
  - wavpack
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_dvd
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s8_planar
  - pcm_s16be
  - pcm_s16be_planar
  - pcm_s16le
  - pcm_s16le_planar
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s24le_planar
  - pcm_s32be
  - pcm_s32le
  - pcm_s32le_planar
  - pcm_s64be
  - pcm_s64le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - pcm_vidc
  - roq_dpcm
  - adpcm_adx
  - adpcm_argo
  - g722
  - g726
  - g726le
  - adpcm_ima_amv
  - adpcm_ima_alp
  - adpcm_ima_apm
  - adpcm_ima_qt
  - adpcm_ima_ssi
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libmp3lame
  - libopus
  - libvorbis
  - a64multi
  - a64multi5
  - alias_pix
  - amv
  - apng
  - asv1
  - asv2
  - avrp
  - avui
  - ayuv
  - bmp
  - cfhd
  - cinepak
  - cljr
  - dnxhd
  - dpx
  - dvvideo
  - exr
  - ffv1
  - ffvhuff
  - fits
  - flashsv
  - flashsv2
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpeg2000
  - jpegls
  - ljpeg
  - magicyuv
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - msvideo1
  - pam
  - pbm
  - pcx
  - pfm
  - pgm
  - pgmyuv
  - png
  - ppm
  - prores
  - prores_aw
  - prores_ks
  - qtrle
  - r10k
  - r210
  - rawvideo
  - roqvideo
  - rpza
  - rv10
  - rv20
  - sgi
  - snow
  - speedhq
  - sunrast
  - svq1
  - targa
  - tiff
  - utvideo
  - v210
  - v308
  - v408
  - v410
  - vc2
  - wrapped_avframe
  - wmv1
  - wmv2
  - xbm
  - xface
  - xwd
  - y41p
  - yuv4
  - zlib
  - zmbv
  - libaom-av1
  - libtheora
  - libvpx
  - libvpx-vp9
  - libwebp_anim
  - libwebp
  - libx264
  - libx264rgb
  - libx265
  - h263_v4l2m2m
  - h264_nvenc
  - h264_v4l2m2m
  - h264_vaapi
  - nvenc
  - nvenc_h264
  - nvenc_hevc
  - hevc_nvenc
  - hevc_v4l2m2m
  - hevc_vaapi
  - mjpeg_vaapi
  - mpeg2_vaapi
  - mpeg4_v4l2m2m
  - vp8_v4l2m2m
  - vp8_vaapi
  - vp9_vaapi
[Debug  ] <EncodeDock::EncodeDock> end 
[Debug  ] <JobsDock::JobsDock> begin 
[Debug  ] <JobsDock::JobsDock> end 
[Debug  ] <MainWindow::readWindowSettings> begin 
[Debug  ] <MainWindow::readWindowSettings> end 
[Debug  ] <LeapNetworkListener::start> begin 
[Debug  ] <MainWindow::MainWindow> end 
[Debug  ] <MainWindow::changeTheme> end 
[Debug  ] <FiltersDock::resetQview> begin 
[Debug  ] <KeyframesDock::load> begin

What did I do wrong?

Nothing. It is probably incompatible with your OpenGL. Both FiltersDock and KeyframesDock - the last two log messages - did not complete and use Qt Quick QML, which requires a compatible OpenGL system as explained in the FAQ and elsewhere. It is working good for me with AMD graphics:

ddennedy@Gamerbox-9400:~/src/shotcut$ glxinfo | grep OpenGL
OpenGL vendor string: AMD
OpenGL renderer string: Radeon RX 560 Series (POLARIS11, DRM 3.35.0, 5.4.0-94-generic, LLVM 12.0.0)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.0.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.0.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Thanks for your reply! I have always been using the integrated graphics of my Intel Core i5 5th gen CPU.

Hmmmmmmm :thinking:

user@PC:~$ glxinfo | grep OpenGL
bash: glxinfo: command not found

Last time I upgraded my system I did an autopurge but I didn’t see Mesa or OpenGL packets being removed. Currently:

user@PC:~$ sudo apt list --installed *mesa*
Listing... Done
libegl-mesa0/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
libgl1-mesa-dev/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
libgl1-mesa-dri/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
libglapi-mesa/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
libglu1-mesa-dev/unstable,now 9.0.1-1 amd64 [installed,automatic]
libglu1-mesa/unstable,now 9.0.1-1 amd64 [installed,automatic]
libglx-mesa0/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
mesa-va-drivers/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
mesa-vdpau-drivers/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]
mesa-vulkan-drivers/now 21.3.4-1 amd64 [installed,upgradable to: 21.3.5-1]

sudo apt list --installed *opengl*
Listing... Done
libopengl-dev/unstable,now 1.4.0-1 amd64 [installed,automatic]
libopengl0/unstable,now 1.4.0-1 amd64 [installed,automatic]
libqt5opengl5-dev/unstable,now 5.15.2+dfsg-14 amd64 [installed,automatic]
libqt5opengl5/unstable,now 5.15.2+dfsg-14 amd64 [installed,automatic]

I have upgraded my system again and Shotcut still doesn’t open :expressionless:

You know what? Let’s call it a day. It is probably Debian Unstable packets breaking the dependencies required by Shotcut. I’ll figure out this mess another time, I’ll use Shotcut on Windows in the meanwhile.

Thank you very much for your help people :slightly_smiling_face:
None of my posts have been left without answers and I appreciate that :slightly_smiling_face:

Take care!

1 Like

To those looking for a solution, simply prefer installing Shotcut from Flatpak as it is built by the developers rather than the Debian version which is not.

Take care everyone.

Sorry to disagree!

It is very important to know why things don’t work, so things can get fixed. Asking someone (like @daviwph does) to use the windows version instead, is how can I say… “not intelligent”. Let alone the fact that it is no one’s business why I use Debian and not Linux… Shotcut is supposed to work on multiple platforms. Switching OS is simply ignoring the problem. I do not have windows, by the way… but it is not anyone business.

When you install software from places you don’t even remember where, link is your case with ffmpeg, you end up with lots of dependencies you do not understand. For example, I was making some tests with Shotcut code, so I do use, right now, a self compiled version of Shotcut and MLT. But to be honest with you, I never know if my self compiled Shotcut is using the self compiled MLT / frei0r, or if it uses the system wide MLT / frei0r.

When you install form Debian, you know that there are maintainers selected through a very, very rigid process. Basically, you know WHO you TRUST. Packages are signed by those people. When you use flatpack, for example, you are installing a whole sandbox full of packages you have no idea where they come from.

Your system will be full of repeated packages you never know what is updated and what is not. Of course, for you, maintenance can be much easier, if all you have to do is uninstall you sandbox and reinstall it.

The same is true for those who go like:

$ pip install -e .

You have no idea what you are installing and who you trust.

Many workarounds can be useful. You can use flatpack. You can compile yourself. You can use other OS if you have one. But, at the end of the day, package maintainers should be informed about the problem, so they can get it fixed.

I just helped a guy who’s using the “Ubuntu Repository” version of Shotcut that fails to export his video. The fix was to install the OFFICIALLY SUPPORTED version from the Shotcut Download website. The version in “Ubuntu Repository” and by extension the Debian one is not supported by the developer(s) of Shotcut.

I’m sure this guy is not the only one using Shotcut on Ubuntu and clearly not many of those who are have this same problem, or if they are they aren’t reporting it - not on the forum, nor to the “package maintainers”. The last time this problem was reported it was in June from a user on a Fedora system and again the solution was to use the officially supported version from the Shotcut Download page.

You cannot blame users. Most users of applications like Shotcut just want a video editor that works. They don’t want to spend hours reporting problems to O/S manufacturers in the hope of getting a solution. I suspect many don’t know how to report a problem to the “package maintainers”. They ask a question on this forum, and if lucky they get a solution within a few hours then they get on with video editing, especially when the answer is “Use the officially supported package”.

1 Like

By using one of our builds, the user can confirm things working as intended and then report a problem with a package to their distribution.

1 Like

Dear @Elusien,

It is the first time I see you in this discussion. I am not complaining about the “workaround”. I am not complaining about you having helped some guy. I am complaining about advising people to prefer a flatpack build over the official packages.

I don’t see this post being about finding a workaround! It is a “bug report”. A workaround is not a solution to a bug report. In a complex software like Shotcut, many bugs are hidden to most users.

The way this bug was “closed” looks like a “wont fix” together with a “workaround”. This is fine by me.

Shotcut should, IMHO, preferably be packaged by package maintainers. I don’t blame @shotcut maintainers for their being unhappy with problems caused by packages built by other people. But it does also expose problems with Shotcut / MLT itself!

Should Shotcut crash because of some library is not installed???

If Shotcut crashes for some uninstalled library… isn’t it a bug in Shotcut? Is it a won’t fix?

If ffmpeg does not have this so called VAAPI, shouldn’t Shotcut warn the user about this fact?

When I report a bug, I am very glad for having workarounds. But I am specially interested in contributing (not with code, just the report itself). I want the code to get better and better. A workaround doesn’t do that.

As it is designed, Shotcut should work on windows, GNU / Linux, Mac OS, FreeBSD… be it Debian, Ubuntu, Fedora, etc, etc, etc. If I find a bug in Ubuntu’s Shotcut, the bug is there! On the code!!! Even if other people don’t see it. Maybe the bug appears to me, because my compiler optimizes different from yours. Shall we blame the compiler? Shall we blame the optimization setting?

I am NOT blaming users. I am advocating against an advise that tells people to prefer some flatpack over distro package. It is a workaround that should, IMO, be used in seldom cases. But when someone says

I don’t care, I did not build this package.

He is, in a sense, blaming the user for using a distro package.

I think that when people report a bug for some Debian package, the person can be given the flatpack workaround. But it is simply not a solution to the bug. There could be, for example, a mechanism (full solution, with protocols / procedures) to communicate with Debian / Fedora / Ubuntu maintainers, and get them to work for you!!!

Having Shotcut work smoothly in any distro, with any packaging solution, compiled by any compiler with different settings, with or without some libraries installed, shows that Shotcut is stable and reliable. Shotcut should not blame users for choosing a distro package. It should, IMHO, make an effort to make it work.

Yes! It is a very good thing to ask!

However, IMHO, people should not advise someone to prefer flatpack over official distro, just because one is build by the developers.

People should offer whatever advice they think might help. The person who offered that advice had no way of knowing that you would refuse to use the build that is supported by the developers here on this forum.

Distro packages are not supported by the developers on this forum. However, sometimes packagers come to this forum with specific questions about compiling or dependencies and we are able to offer suggestions.

I would be interested to know if the official Shotcut builds (Flatpack or portable tar) work correctly on your system:

Are you able to test that and report back?

1 Like

Sorry, @brian… but you are just provoking me, because I am saying that a robust software should be designed to smoothly work on a distro native packaging system. Shotcut should not crash when libraries are not available. Shotcut should ideally warn the user if ffmpeg is compiled without XYZ support. Etc, etc, etc. Providing a sandbox is at the same time a good thing on the short term, but it is at the same time, sweeping bugs to under the rug.

Robust software works correctly when packaged. A workaround is not a solution to bugs.

I do not want to provoke you. Unfortunately, you will be disappointed to know that there are no volunteers here on this forum who support distro packages.

By the way, I still think about the audio alignment work that you did last year - I plan to integrate it into Shotcut sometime this year. You are certainly a capable software developer. Maybe you will volunteer to help make Shotcut work better in distro packages. Patches are very much welcome on the github project.

1 Like