Shotcut Freezes when pressing play

I created a project, which I could play without problems. At some point Shotcut froze, so I killed it. I restarted it and opened the project. The program indicates there are some saved snapshots, asking whether I want to restore them. I answer “yes”. The project loads fine, and I seem to be able to edit it (for example, i could remove an audio track). However, as soon as I press the “play” button Shotcut freezes. I tried this multiple times, and it happens consistently. I also tried not restoring the saved snapshot, and the same happens.

I’d be happy to provide any information you requested.

  • Shotcut version 17.10.02 (tried to upgrade to 17.12.03, but not clear to me what to do after pressing the “Click Here to get it” message, nothing happens)

  • uname -a: Linux pegasus 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


Note: I tried rebooting the system, but the same problem happens.

I downloaded version 17.12.03, but the same bug is present.

This seem to have to do with the fact that the beginning of my video has the same clip in two tracks, with one of them having some text and a fade-in fade out transition (trick to have the text fade in an out). If I move the cursor beyond that first clip, it plays ok.

If I select a clip from the playlist and play a bit of it, and THEN select the editing with cursor at the beginning and play, it runs ok. However if I pause and resume while on that first clip, it freezes again. See screenshot for how the beginning of the tracks look like:

hawaii_2017.mlt (270.4 KB)

I’m also attaching my project mlt file.

Just use a transparent png with text on it to do your text fade in & out.
And let a second at the start to see if it changes.