Shotcut Export Failing


So I did a project on Shotcut that took me hours to create. Whenever I try exporting this project, it reaches around 55%, and then fails. I tried going from 1920x1080 25fps to 1280x720 25fps. Still keeps failing on export. I am using Windows 10 home. How can I fix this?

Any help is appreciated.



Make a copy of the mtl file and try to erase the clips around 55% of the total duration.
Do it again.

Exporting launching the program as admin can work too.

Tried these things, still hasn’t worked. Do you know if there is anything else I can do?


Have you read the job log file? Under the jobs list there’s a “hamburger” or three horizontal lines. Click on the hamburger, and one of the choices displayed is displaying the job log. You’ll probably see an error message at the bottom of the file. If its meaning isn’t obvious (can’t open file, out of room, etc.), report it here. Maybe someone can tell you what it means.

Or try again cut the project at 33%, 66% and end to see if the 3 third exports OK.

Not sure if this applies to your problem
But I just did find out that ShotCut fails on the export of files (Visual filters and other settings, audio filters seem to work) when you use it in another language than your OS … e.g. your OS is set to Franch and you use ShotCut in english.
Changing the language in ShotCut fixes it.

Shotcut version 17,03,02
Windows 10 64bit, Build 14393

Edit: Shotcut version 17,04,02 seems to have fixed that issue !

I’m having the same problem. Windows 10, Shotcut version 17.10.02. I’ve used a fair amount of effects on this Title screen Video (composed entirely of still picture with effects), and am using one wav file for the audio part, trying to make a youtube title screen video. I used standard export settings. This happened a few weeks back and I kept fiddling with stuff like diminishing bitrates and quality settings, and eventually it exported, but I can’t remember what I did and don’t want to spend more hours fiddling. The log file looks like this:

If you can’t see it, it has quite a few lines, ending with:
[mp4 @ 000000000820b3c0] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead
Then it has a bunch of lines:
Current Frame: 4908, percentage: 77

Please help!



OK, I have answered my own question. I reset ALL the export parameters using the reset button on the bottom of the export control box. Then I UN-checked “Parallel Processing”, and the job ran to completion with no further changes.
This time the log file looks like this:

Why use such an old version? Shotcut is updated every month to fix bugs and add new features.