Shotcut.exe has stopped working using Windows 7

I downloaded Shotcut yesterday and made a beautiful video today I started to edit a new video and got the error message. I proceeded to uninstall and tick the Registry option still the same results. Yesterday I also downloaded Shotcut to my laptop that is also running Windows 7 and today I received the same error message.

Did you download the correct version for windows? There is a 32 bit version of Shotcut separate from the 64 bit one. You might have unknowingly downloaded the wrong one if you aren’t sure of your operating system’s bit version.

Otherwise I do not know. I use Windows 10 and OSX.

Well I guess that I will reverse direction and have my son-in-law load Linux and try it that way. I am really looking forward to using Shotcut.

I’m sorry to say I don’t know how to help :grimacing:
I hope it works out on Linux for you. Maybe it’s just something like the OS is not up to date? I don’t know.

I guess that this might be part of the price that I have to pay for not going to Windows 10 and I have been seriously considering learning Linux anyway. It is just happening a bit sooner than I anticipated.